summaryrefslogtreecommitdiffstats
path: root/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:37:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:37:43 +0000
commit32d0011be42ca05099175cd82210e02a56ef2a54 (patch)
tree5c0afe509e617e7ca4703bd895afc8b1fb342632 /debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
parentAdding upstream version 2023.03.04. (diff)
downloadyt-dlp-debian.tar.xz
yt-dlp-debian.zip
Adding debian version 2023.03.04-1.debian/2023.03.04-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch')
-rw-r--r--debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch b/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
new file mode 100644
index 0000000..5c254f4
--- /dev/null
+++ b/debian/patches/0004-Makefile-Don-t-run-flake8-when-running-offlinetest.patch
@@ -0,0 +1,25 @@
+From: =?utf-8?q?Rog=C3=A9rio_Brito?= <rbrito@gmail.com>
+Date: Sun, 22 Nov 2020 20:06:55 -0300
+Subject: Makefile: Don't run flake8 when running offlinetest.
+
+Unfortunately, due to the dynamic nature of python, we most certainly would
+like to run flake8 when testing the package. Alas, flake8 sometimes
+generates style-only warning or "errors" that break the build, in a similar
+fashion to what -Werror does to GCC or other compilers.
+
+Therefore, I'm disabling this.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Makefile 2022-10-04 04:51:46.307487019 -0400
++++ b/Makefile 2022-10-04 04:51:46.303487036 -0400
+@@ -70,7 +70,7 @@
+ $(PYTHON) -m pytest
+ $(MAKE) codetest
+
+-offlinetest: codetest
++offlinetest:
+ $(PYTHON) -m pytest -k "not download"
+
+ # XXX: This is hard to maintain