summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d4a3a57
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = yt_dlp
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ python3 devscripts/set-variant.py debian -M "As yt-dlp has been installed via apt, you should use that to update. If you're on a stable release, also check backports."
+ rm yt-dlp
+
+override_dh_clean:
+ make clean
+ dh_clean
+
+override_dh_auto_test:
+ make offlinetest PYTHON=python3
+
+override_dh_installchangelogs:
+ DEB_BUILD_OPTIONS=notrimdch dh_installchangelogs Changelog.md
+
+override_dh_gencontrol:
+ dh_gencontrol -- -Vyt-dlp:Sites="$$(sed -n -e 's/.* \- \*\*//g' -e 's/:.*//' -e 's/\*\*.*/,/p' supportedsites.md | fmt )"