summaryrefslogtreecommitdiffstats
path: root/ridljar/Module_ridljar.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /ridljar/Module_ridljar.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ridljar/Module_ridljar.mk')
-rw-r--r--ridljar/Module_ridljar.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/ridljar/Module_ridljar.mk b/ridljar/Module_ridljar.mk
new file mode 100644
index 000000000..3d286c546
--- /dev/null
+++ b/ridljar/Module_ridljar.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,ridljar))
+
+ifneq ($(ENABLE_JAVA),)
+
+$(eval $(call gb_Module_add_targets,ridljar,\
+ CustomTarget_javamaker \
+ Jar_libreoffice \
+ Jar_ridl \
+ Jar_unoloader \
+))
+
+$(eval $(call gb_Module_add_check_targets,ridljar,\
+ CustomTarget_test_urp \
+ InternalUnoApi_test_urp \
+ JunitTest_bridgefactory \
+ JunitTest_connections \
+ JunitTest_java \
+ JunitTest_java_remote \
+ JunitTest_remote \
+ JunitTest_typedesc \
+ JunitTest_uno \
+ JunitTest_urp \
+ JunitTest_util \
+))
+endif
+
+# vim:set noet sw=4 ts=4: