summaryrefslogtreecommitdiffstats
path: root/stoc/Module_stoc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /stoc/Module_stoc.mk
parentInitial commit. (diff)
downloadlibreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.tar.xz
libreoffice-940b4d1848e8c70ab7642901a68594e8016caffc.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'stoc/Module_stoc.mk')
-rw-r--r--stoc/Module_stoc.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/stoc/Module_stoc.mk b/stoc/Module_stoc.mk
new file mode 100644
index 000000000..d05c53d55
--- /dev/null
+++ b/stoc/Module_stoc.mk
@@ -0,0 +1,36 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,stoc))
+
+$(eval $(call gb_Module_add_targets,stoc,\
+ Library_bootstrap \
+ Library_introspection \
+ Library_invocadapt \
+ Library_invocation \
+ Library_namingservice \
+ Library_proxyfac \
+ Library_reflection \
+ Library_stocservices \
+))
+
+ifeq ($(ENABLE_JAVA),TRUE)
+
+$(eval $(call gb_Module_add_targets,stoc,\
+ Library_javaloader \
+ Library_javavm \
+))
+
+endif
+
+$(eval $(call gb_Module_add_check_targets,stoc, \
+ CppunitTest_stoc_uriproc \
+))
+
+# vim:set noet sw=4 ts=4: