summaryrefslogtreecommitdiffstats
path: root/vcl/Executable_vcldemo.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 16:51:28 +0000
commit940b4d1848e8c70ab7642901a68594e8016caffc (patch)
treeeb72f344ee6c3d9b80a7ecc079ea79e9fba8676d /vcl/Executable_vcldemo.mk
parentInitial commit. (diff)
downloadlibreoffice-upstream.tar.xz
libreoffice-upstream.zip
Adding upstream version 1:7.0.4.upstream/1%7.0.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vcl/Executable_vcldemo.mk')
-rw-r--r--vcl/Executable_vcldemo.mk68
1 files changed, 68 insertions, 0 deletions
diff --git a/vcl/Executable_vcldemo.mk b/vcl/Executable_vcldemo.mk
new file mode 100644
index 000000000..a9a8d195f
--- /dev/null
+++ b/vcl/Executable_vcldemo.mk
@@ -0,0 +1,68 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,vcldemo))
+
+$(eval $(call gb_Executable_use_api,vcldemo,\
+ offapi \
+ udkapi \
+))
+
+$(eval $(call gb_Executable_use_externals,vcldemo,\
+ boost_headers \
+ glm_headers \
+ harfbuzz \
+))
+ifeq ($(DISABLE_GUI),)
+$(eval $(call gb_Executable_use_externals,vcldemo,\
+ epoxy \
+))
+endif
+
+$(eval $(call gb_Executable_add_defs,vcldemo,\
+ -DVCL_INTERNALS \
+))
+
+$(eval $(call gb_Executable_set_include,vcldemo,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/vcl/inc \
+))
+
+$(eval $(call gb_Executable_use_libraries,vcldemo,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ tl \
+ sal \
+ salhelper \
+ vcl \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,vcldemo,\
+ vcl/workben/vcldemo \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,vcldemo,\
+ vclmain \
+))
+
+ifeq ($(OS), $(filter LINUX %BSD SOLARIS, $(OS)))
+$(eval $(call gb_Executable_add_libs,vcldemo,\
+ -lm $(DLOPEN_LIBS) \
+ -lX11 \
+))
+
+$(eval $(call gb_Executable_use_static_libraries,vcldemo,\
+ glxtest \
+))
+endif
+
+# vim: set noet sw=4 ts=4: