summaryrefslogtreecommitdiffstats
path: root/debian/patches/no-check-if-root.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/no-check-if-root.diff')
-rw-r--r--debian/patches/no-check-if-root.diff26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/no-check-if-root.diff b/debian/patches/no-check-if-root.diff
new file mode 100644
index 000000000..95ebbb329
--- /dev/null
+++ b/debian/patches/no-check-if-root.diff
@@ -0,0 +1,26 @@
+--- a/Makefile.in 2017-07-28 06:09:37.072183489 +0000
++++ b/Makefile.in 2017-10-18 12:43:59.215567467 +0000
+@@ -57,14 +57,6 @@ else # MAKE_RESTARTS
+
+ .DEFAULT_GOAL := build
+
+-check-if-root:
+- @if test ! `uname` = 'Haiku' -a `id -u` = 0 && ! grep -q 'lxc\|docker' /proc/self/cgroup && ! grep -q 'libpod_parent' /proc/self/cgroup; then \
+- echo; \
+- echo 'Building LibreOffice as root is a very bad idea, use a regular user.'; \
+- echo; \
+- exit 1; \
+- fi
+-
+ gb_Side ?= host
+
+ include $(BUILDDIR)/config_$(gb_Side).mk
+@@ -252,7 +244,7 @@ endif
+ #
+ # Bootstrap
+ #
+-bootstrap: check-if-root compilerplugins
++bootstrap: compilerplugins
+
+ #
+ # Build