summaryrefslogtreecommitdiffstats
path: root/test/TEST-01-BASIC
diff options
context:
space:
mode:
Diffstat (limited to 'test/TEST-01-BASIC')
-rw-r--r--test/TEST-01-BASIC/Makefile6
-rwxr-xr-xtest/TEST-01-BASIC/test.sh25
2 files changed, 31 insertions, 0 deletions
diff --git a/test/TEST-01-BASIC/Makefile b/test/TEST-01-BASIC/Makefile
new file mode 100644
index 0000000..79fe968
--- /dev/null
+++ b/test/TEST-01-BASIC/Makefile
@@ -0,0 +1,6 @@
+BUILD_DIR=$(shell ../../tools/find-build-dir.sh)
+
+all setup run clean clean-again:
+ @basedir=../.. TEST_BASE_DIR=../ BUILD_DIR=$(BUILD_DIR) ./test.sh --$@
+
+.PHONY: all setup run clean clean-again
diff --git a/test/TEST-01-BASIC/test.sh b/test/TEST-01-BASIC/test.sh
new file mode 100755
index 0000000..58f6cd1
--- /dev/null
+++ b/test/TEST-01-BASIC/test.sh
@@ -0,0 +1,25 @@
+#!/usr/bin/env bash
+set -e
+TEST_DESCRIPTION="Basic systemd setup"
+IMAGE_NAME="basic"
+RUN_IN_UNPRIVILEGED_CONTAINER=${RUN_IN_UNPRIVILEGED_CONTAINER:-yes}
+TEST_REQUIRE_INSTALL_TESTS=0
+
+. $TEST_BASE_DIR/test-functions
+
+test_create_image() {
+ create_empty_image_rootdir
+
+ # Create what will eventually be our root filesystem onto an overlay
+ (
+ LOG_LEVEL=5
+ setup_basic_environment
+
+ # install tests manually so the test is functional even when -Dinstall-tests=false
+ mkdir -p $initdir/usr/lib/systemd/tests/testdata/units/
+ cp -v $(dirname $0)/../units/{testsuite-01,end}.service $initdir/usr/lib/systemd/tests/testdata/units/
+ )
+ setup_nspawn_root
+}
+
+do_test "$@" 01