summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 07:24:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 07:24:23 +0000
commit1e99b22ed2aa3bfed7ae8a7c1ca5c4bb99148a0e (patch)
treeff57125a72fceeaa526bb76fda2bcd1adfd4c20f /debian/patches
parentAdding upstream version 1:9.16.44. (diff)
downloadbind9-debian.tar.xz
bind9-debian.zip
Adding debian version 1:9.16.44-1~deb11u1.debian/1%9.16.44-1_deb11u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Add_--install-layout=deb_to_setup.py_call.patch24
-rw-r--r--debian/patches/0002-python-fix-for-dist-packages.patch49
-rw-r--r--debian/patches/0003-Disable-sphinx-build-strict-mode.patch33
-rw-r--r--debian/patches/series3
4 files changed, 109 insertions, 0 deletions
diff --git a/debian/patches/0001-Add_--install-layout=deb_to_setup.py_call.patch b/debian/patches/0001-Add_--install-layout=deb_to_setup.py_call.patch
new file mode 100644
index 0000000..0ef8534
--- /dev/null
+++ b/debian/patches/0001-Add_--install-layout=deb_to_setup.py_call.patch
@@ -0,0 +1,24 @@
+From: Debian DNS Packaging <pkg-dns-devel@lists.alioth.debian.org>
+Date: Fri, 24 Nov 2017 16:26:55 +0000
+Subject: Add_--install-layout=deb_to_setup.py_call
+
+---
+ bin/python/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/bin/python/Makefile.in b/bin/python/Makefile.in
+index dc1af40..a87927a 100644
+--- a/bin/python/Makefile.in
++++ b/bin/python/Makefile.in
+@@ -45,9 +45,9 @@ install:: ${TARGETS} installdirs
+ ${INSTALL_SCRIPT} dnssec-keymgr ${DESTDIR}${sbindir}
+ if test -n "${PYTHON}" ; then \
+ if test -n "${DESTDIR}" ; then \
+- ${PYTHON} ${srcdir}/setup.py install --root=${DESTDIR} --prefix=${prefix} @PYTHON_INSTALL_LIB@ ; \
++ ${PYTHON} ${srcdir}/setup.py install --root=${DESTDIR} --prefix=${prefix} @PYTHON_INSTALL_LIB@ --install-layout=deb ; \
+ else \
+- ${PYTHON} ${srcdir}/setup.py install --prefix=${prefix} @PYTHON_INSTALL_LIB@ ; \
++ ${PYTHON} ${srcdir}/setup.py install --prefix=${prefix} @PYTHON_INSTALL_LIB@ --install-layout=deb ; \
+ fi ; \
+ rm -rf build ; \
+ fi
diff --git a/debian/patches/0002-python-fix-for-dist-packages.patch b/debian/patches/0002-python-fix-for-dist-packages.patch
new file mode 100644
index 0000000..971bfa0
--- /dev/null
+++ b/debian/patches/0002-python-fix-for-dist-packages.patch
@@ -0,0 +1,49 @@
+From: Jim Popovitch <jimpop@domainmail.org>
+Date: Sat, 13 Jul 2019 17:00:35 +0000
+Subject: python fix for dist-packages
+
+---
+ bin/python/dnssec-checkds.py.in | 2 +-
+ bin/python/dnssec-coverage.py.in | 2 +-
+ bin/python/dnssec-keymgr.py.in | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/bin/python/dnssec-checkds.py.in b/bin/python/dnssec-checkds.py.in
+index 3ec15e2..e70d0c4 100644
+--- a/bin/python/dnssec-checkds.py.in
++++ b/bin/python/dnssec-checkds.py.in
+@@ -22,7 +22,7 @@ if os.name != "nt":
+ sys.path.insert(
+ 1,
+ os.path.join(
+- "@prefix@", "lib", "python" + sys.version[:3], "site-packages"
++ "@prefix@", "lib", "python" + sys.version[:3], "dist-packages"
+ ),
+ )
+
+diff --git a/bin/python/dnssec-coverage.py.in b/bin/python/dnssec-coverage.py.in
+index a82dfe3..7d4f6ba 100644
+--- a/bin/python/dnssec-coverage.py.in
++++ b/bin/python/dnssec-coverage.py.in
+@@ -22,7 +22,7 @@ if os.name != "nt":
+ sys.path.insert(
+ 1,
+ os.path.join(
+- "@prefix@", "lib", "python" + sys.version[:3], "site-packages"
++ "@prefix@", "lib", "python" + sys.version[:3], "dist-packages"
+ ),
+ )
+
+diff --git a/bin/python/dnssec-keymgr.py.in b/bin/python/dnssec-keymgr.py.in
+index f8ee013..3bfa02e 100644
+--- a/bin/python/dnssec-keymgr.py.in
++++ b/bin/python/dnssec-keymgr.py.in
+@@ -22,7 +22,7 @@ if os.name != "nt":
+ sys.path.insert(
+ 1,
+ os.path.join(
+- "@prefix@", "lib", "python" + sys.version[:3], "site-packages"
++ "@prefix@", "lib", "python" + sys.version[:3], "dist-packages"
+ ),
+ )
+
diff --git a/debian/patches/0003-Disable-sphinx-build-strict-mode.patch b/debian/patches/0003-Disable-sphinx-build-strict-mode.patch
new file mode 100644
index 0000000..e9d7406
--- /dev/null
+++ b/debian/patches/0003-Disable-sphinx-build-strict-mode.patch
@@ -0,0 +1,33 @@
+From: =?utf-8?b?T25kxZllaiBTdXLDvQ==?= <ondrej@debian.org>
+Date: Wed, 21 Sep 2022 12:53:09 +0200
+Subject: Disable sphinx-build strict mode
+
+---
+ doc/arm/Makefile.in | 1 -
+ doc/man/Makefile.in | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/doc/arm/Makefile.in b/doc/arm/Makefile.in
+index ce365e3..806f577 100644
+--- a/doc/arm/Makefile.in
++++ b/doc/arm/Makefile.in
+@@ -29,7 +29,6 @@ SPHINXBUILD = @SPHINX_BUILD@
+ SPHINXBUILDDIR = ${builddir}/_build
+
+ common_SPHINXOPTS = \
+- -W \
+ -a \
+ -v \
+ -c "${abs_srcdir}"
+diff --git a/doc/man/Makefile.in b/doc/man/Makefile.in
+index 75794f7..70b66a2 100644
+--- a/doc/man/Makefile.in
++++ b/doc/man/Makefile.in
+@@ -161,7 +161,6 @@ SPHINXBUILDDIR = ${builddir}/_build
+ SPHINX_W = -W
+
+ common_SPHINXOPTS = \
+- $(SPHINX_W) \
+ -a \
+ -v \
+ -c "${abs_srcdir}"
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..12673d3
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+0001-Add_--install-layout=deb_to_setup.py_call.patch
+0002-python-fix-for-dist-packages.patch
+0003-Disable-sphinx-build-strict-mode.patch