summaryrefslogtreecommitdiffstats
path: root/contrib/dlz/bin/dlzbdb/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/dlz/bin/dlzbdb/Makefile.in')
-rw-r--r--contrib/dlz/bin/dlzbdb/Makefile.in56
1 files changed, 56 insertions, 0 deletions
diff --git a/contrib/dlz/bin/dlzbdb/Makefile.in b/contrib/dlz/bin/dlzbdb/Makefile.in
new file mode 100644
index 0000000..345c54b
--- /dev/null
+++ b/contrib/dlz/bin/dlzbdb/Makefile.in
@@ -0,0 +1,56 @@
+# Copyright (C) 1998-2001, 2016 Internet Systems Consortium, Inc. ("ISC")
+# Copyright (C) Internet Systems Consortium, Inc. ("ISC")
+#
+# SPDX-License-Identifier: MPL-2.0
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, you can obtain one at https://mozilla.org/MPL/2.0/.
+#
+# See the COPYRIGHT file distributed with this work for additional
+# information regarding copyright ownership.
+
+srcdir = @srcdir@
+VPATH = @srcdir@
+top_srcdir = @top_srcdir@
+
+VERSION=@BIND9_VERSION@
+
+@BIND9_MAKE_INCLUDES@
+
+DLZINCLUDES = @DLZ_DRIVER_INCLUDES@
+
+CINCLUDES = -I${srcdir}/include -I${srcdir}/unix/include \
+ ${ISC_INCLUDES} ${DLZINCLUDES}
+
+CDEFINES = @CONTRIB_DLZ@
+CWARNINGS =
+
+DLZLIBS = @DLZ_DRIVER_LIBS@
+ISCLIBS = ../../../../lib/isc/libisc.@A@ @NO_LIBTOOL_ISCLIBS@
+
+DEPLIBS = ${ISCDEPLIBS}
+
+LIBS = ${ISCLIBS} ${DLZLIBS} @LIBS@
+
+TARGETS = dlzbdb
+
+SRCS = dlzbdb.c
+
+@BIND9_MAKE_RULES@
+
+dlzbdb.@O@: dlzbdb.c
+ ${LIBTOOL_MODE_COMPILE} ${CC} ${ALL_CFLAGS} -DVERSION=\"${VERSION}\" \
+ -c ${srcdir}/dlzbdb.c
+
+dlzbdb: dlzbdb.@O@ ${DEPLIBS}
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} -o $@ dlzbdb.@O@ ${LIBS}
+
+clean distclean maintainer-clean::
+ rm -f ${TARGETS}
+
+installdirs:
+ $(SHELL) ${top_srcdir}/mkinstalldirs ${DESTDIR}${sbindir}
+
+install:: dlzbdb installdirs
+ ${LIBTOOL_MODE_INSTALL} ${INSTALL_PROGRAM} dlzbdb ${DESTDIR}${sbindir}