summaryrefslogtreecommitdiffstats
path: root/fuzz/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'fuzz/Makefile.in')
-rw-r--r--fuzz/Makefile.in55
1 files changed, 55 insertions, 0 deletions
diff --git a/fuzz/Makefile.in b/fuzz/Makefile.in
new file mode 100644
index 0000000..e62ed15
--- /dev/null
+++ b/fuzz/Makefile.in
@@ -0,0 +1,55 @@
+# Copyright (C) Internet Systems Consortium, Inc. ("ISC")
+#
+# SPDX-License-Identifier: MPL-2.0
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, you can obtain one at https://mozilla.org/MPL/2.0/.
+#
+# See the COPYRIGHT file distributed with this work for additional
+# information regarding copyright ownership.
+
+srcdir = @srcdir@
+VPATH = @srcdir@
+top_srcdir = @top_srcdir@
+abs_srcdir = @abs_srcdir@
+
+@BIND9_MAKE_INCLUDES@
+
+CINCLUDES = -I. -I.. ${DNS_INCLUDES} ${ISC_INCLUDES} \
+ ${OPENSSL_CFLAGS}
+CDEFINES = -DFUZZDIR=\"$(abs_srcdir)\"
+
+ISCLIBS = ../lib/isc/libisc.@A@ @NO_LIBTOOL_ISCLIBS@
+ISCDEPLIBS = ../lib/isc/libisc.@A@
+DNSLIBS = ../lib/dns/libdns.@A@ @NO_LIBTOOL_DNSLIBS@
+DNSDEPLIBS = ../lib/dns/libdns.@A@
+
+LIBS = @LIBS@
+
+OBJS = main.@O@
+SRCS = main.c dns_name_fromtext_target.c dns_rdata_fromwire_text.c
+
+SUBDIRS =
+TARGETS = dns_name_fromtext_target@EXEEXT@ \
+ dns_rdata_fromwire_text@EXEEXT@
+
+@BIND9_MAKE_RULES@
+
+dns_name_fromtext_target@EXEEXT@: dns_name_fromtext_target.@O@ main.@O@ ${ISCDEPLIBS} ${DNSDEPLIBS}
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
+ dns_name_fromtext_target.@O@ main.@O@ ${DNSLIBS} ${ISCLIBS} ${LIBS}
+
+dns_rdata_fromwire_text@EXEEXT@: dns_rdata_fromwire_text.@O@ main.@O@ ${ISCDEPLIBS} ${DNSDEPLIBS}
+ ${LIBTOOL_MODE_LINK} ${PURIFY} ${CC} ${CFLAGS} ${LDFLAGS} -o $@ \
+ dns_rdata_fromwire_text.@O@ main.@O@ ${DNSLIBS} ${ISCLIBS} ${LIBS}
+
+check: ${TARGETS}
+ for fuzzer in ${TARGETS}; do \
+ ./$${fuzzer} ; \
+ done
+
+oss-fuzz: ${TARGETS}
+
+clean distclean::
+ rm -f ${TARGETS}