summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/beast/test/example
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/boost/libs/beast/test/example
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/beast/test/example')
-rw-r--r--src/boost/libs/beast/test/example/CMakeLists.txt10
-rw-r--r--src/boost/libs/beast/test/example/Jamfile20
-rw-r--r--src/boost/libs/beast/test/example/common/CMakeLists.txt31
-rw-r--r--src/boost/libs/beast/test/example/common/Jamfile27
-rw-r--r--src/boost/libs/beast/test/example/common/root_certificates.cpp11
-rw-r--r--src/boost/libs/beast/test/example/common/server_certificate.cpp11
6 files changed, 110 insertions, 0 deletions
diff --git a/src/boost/libs/beast/test/example/CMakeLists.txt b/src/boost/libs/beast/test/example/CMakeLists.txt
new file mode 100644
index 00000000..00d48e8e
--- /dev/null
+++ b/src/boost/libs/beast/test/example/CMakeLists.txt
@@ -0,0 +1,10 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+add_subdirectory (common)
diff --git a/src/boost/libs/beast/test/example/Jamfile b/src/boost/libs/beast/test/example/Jamfile
new file mode 100644
index 00000000..b8a3d14a
--- /dev/null
+++ b/src/boost/libs/beast/test/example/Jamfile
@@ -0,0 +1,20 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+alias run-tests :
+ common//run-tests
+ ;
+
+alias fat-tests ;
+
+explicit fat-tests ;
+
+alias run-fat-tests : common//run-tests ;
+
+explicit run-fat-tests ;
diff --git a/src/boost/libs/beast/test/example/common/CMakeLists.txt b/src/boost/libs/beast/test/example/common/CMakeLists.txt
new file mode 100644
index 00000000..a2c6dfe1
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+GroupSources (include/boost/beast beast)
+GroupSources (example/common common)
+GroupSources (test/extras/include/boost/beast extras)
+GroupSources (test/example/common "/")
+
+add_executable (tests-example-common
+ ${BOOST_BEAST_FILES}
+ ${COMMON_FILES}
+ ${EXTRAS_FILES}
+ Jamfile
+ root_certificates.cpp
+ server_certificate.cpp
+)
+
+target_link_libraries(tests-example-common
+ lib-asio
+ lib-asio-ssl
+ lib-beast
+ lib-test
+ )
+
+set_property(TARGET tests-example-common PROPERTY FOLDER "tests") \ No newline at end of file
diff --git a/src/boost/libs/beast/test/example/common/Jamfile b/src/boost/libs/beast/test/example/common/Jamfile
new file mode 100644
index 00000000..6ae40e51
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/Jamfile
@@ -0,0 +1,27 @@
+#
+# Copyright (c) 2016-2017 Vinnie Falco (vinnie dot falco at gmail dot com)
+#
+# Distributed under the Boost Software License, Version 1.0. (See accompanying
+# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+#
+# Official repository: https://github.com/boostorg/beast
+#
+
+local SOURCES =
+ root_certificates.cpp
+ server_certificate.cpp
+ ;
+
+local RUN_TESTS ;
+
+local libs =
+ /boost/beast//lib-asio-ssl
+ /boost/beast/test//lib-test
+ ;
+
+for local f in $(SOURCES)
+{
+ RUN_TESTS += [ run $(f) $(libs) ] ;
+}
+
+alias run-tests : $(RUN_TESTS) ;
diff --git a/src/boost/libs/beast/test/example/common/root_certificates.cpp b/src/boost/libs/beast/test/example/common/root_certificates.cpp
new file mode 100644
index 00000000..780d5ed6
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/root_certificates.cpp
@@ -0,0 +1,11 @@
+//
+// Copyright (c) 2016-2019 Vinnie Falco (vinnie dot falco at gmail dot com)
+//
+// Distributed under the Boost Software License, Version 1.0. (See accompanying
+// file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+//
+// Official repository: https://github.com/boostorg/beast
+//
+
+// Test that header file is self-contained.
+#include "example/common/root_certificates.hpp"
diff --git a/src/boost/libs/beast/test/example/common/server_certificate.cpp b/src/boost/libs/beast/test/example/common/server_certificate.cpp
new file mode 100644
index 00000000..ffb34933
--- /dev/null
+++ b/src/boost/libs/beast/test/example/common/server_certificate.cpp
@@ -0,0 +1,11 @@
+//
+// Copyright (c) 2016-2019 Vinnie Falco (vinnie dot falco at gmail dot com)
+//
+// Distributed under the Boost Software License, Version 1.0. (See accompanying
+// file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+//
+// Official repository: https://github.com/boostorg/beast
+//
+
+// Test that header file is self-contained.
+#include "example/common/server_certificate.hpp"