summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/container/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/boost/libs/container/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/container/CMakeLists.txt')
-rw-r--r--src/boost/libs/container/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/boost/libs/container/CMakeLists.txt b/src/boost/libs/container/CMakeLists.txt
new file mode 100644
index 00000000..8a6428e0
--- /dev/null
+++ b/src/boost/libs/container/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright 2019 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: CMake support for Boost.Container is currently experimental at best
+# and the interface is likely to change in the future
+
+cmake_minimum_required( VERSION 3.5 )
+project( BoostContainer LANGUAGES C CXX )
+
+file( GLOB boost_container_cpp_files src/*.cpp )
+
+add_library(boost_container
+ ${boost_container_cpp_files}
+ src/alloc_lib.c
+)
+
+# This is the public target name, other libraries should link to
+add_library( Boost::container ALIAS boost_container )
+
+target_include_directories( boost_container PUBLIC include )
+
+# NOTE:
+# We deactivate autolinking, because cmake based builds don't need it and
+# we don't implement name mangling for the library file anyway.
+# Ususally the parent CMakeLists.txt file should already have globally defined BOOST_ALL_NO_LIB
+target_compile_definitions( boost_container PUBLIC BOOST_CONTAINER_NO_LIB )
+
+target_link_libraries( boost_container
+ PUBLIC
+ Boost::assert
+ Boost::config
+ Boost::container_hash
+ Boost::core
+ Boost::intrusive
+ Boost::move
+ Boost::static_assert
+ Boost::type_traits
+)