summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/logic/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/boost/libs/logic/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/boost/libs/logic/CMakeLists.txt')
-rw-r--r--src/boost/libs/logic/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/boost/libs/logic/CMakeLists.txt b/src/boost/libs/logic/CMakeLists.txt
new file mode 100644
index 00000000..4951cb62
--- /dev/null
+++ b/src/boost/libs/logic/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyright 2018 Mike Dev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+#
+# NOTE: CMake support for Boost.Logic is currently experimental at best
+# and the interface is likely to change in the future
+
+cmake_minimum_required( VERSION 3.5 )
+project( BoostLogic LANGUAGES CXX )
+
+add_library( boost_logic INTERFACE )
+add_library( Boost::logic ALIAS boost_logic )
+
+target_include_directories( boost_logic INTERFACE include )
+
+target_link_libraries( boost_logic
+ INTERFACE
+ Boost::config
+ Boost::core
+)