summaryrefslogtreecommitdiffstats
path: root/src/civetweb/resources/jni/Android.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/civetweb/resources/jni/Android.mk
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/civetweb/resources/jni/Android.mk')
-rw-r--r--src/civetweb/resources/jni/Android.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/civetweb/resources/jni/Android.mk b/src/civetweb/resources/jni/Android.mk
new file mode 100644
index 00000000..f24981a6
--- /dev/null
+++ b/src/civetweb/resources/jni/Android.mk
@@ -0,0 +1,6 @@
+LOCAL_PATH := $(call my-dir)/../..
+include $(CLEAR_VARS)
+LOCAL_CFLAGS := -std=c99 -O2 -W -Wall -pthread -pipe $(COPT)
+LOCAL_MODULE := civetweb
+LOCAL_SRC_FILES := src\main.c src\civetweb.c
+include $(BUILD_EXECUTABLE)