summaryrefslogtreecommitdiffstats
path: root/src/compressor/zstd
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/compressor/zstd
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/compressor/zstd')
-rw-r--r--src/compressor/zstd/CMakeLists.txt41
-rw-r--r--src/compressor/zstd/CompressionPluginZstd.cc36
-rw-r--r--src/compressor/zstd/CompressionPluginZstd.h43
-rw-r--r--src/compressor/zstd/ZstdCompressor.h106
4 files changed, 226 insertions, 0 deletions
diff --git a/src/compressor/zstd/CMakeLists.txt b/src/compressor/zstd/CMakeLists.txt
new file mode 100644
index 00000000..76709bbb
--- /dev/null
+++ b/src/compressor/zstd/CMakeLists.txt
@@ -0,0 +1,41 @@
+# zstd
+
+# libzstd - build it statically
+set(ZSTD_C_FLAGS "-fPIC -Wno-unused-variable -O3")
+
+include(ExternalProject)
+ExternalProject_Add(zstd_ext
+ SOURCE_DIR ${CMAKE_SOURCE_DIR}/src/zstd/build/cmake
+ CMAKE_ARGS -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
+ -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
+ -DCMAKE_C_FLAGS=${ZSTD_C_FLAGS}
+ -DCMAKE_AR=${CMAKE_AR}
+ -DCMAKE_POSITION_INDEPENDENT_CODE=${ENABLE_SHARED}
+ BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/libzstd
+ BUILD_COMMAND $(MAKE) libzstd_static
+ INSTALL_COMMAND "true")
+
+# force zstd make to be called on each time
+ExternalProject_Add_Step(zstd_ext forcebuild
+ DEPENDEES configure
+ DEPENDERS build
+ COMMAND "true"
+ ALWAYS 1)
+
+add_library(zstd STATIC IMPORTED)
+set_target_properties(zstd PROPERTIES
+ INTERFACE_INCLUDE_DIRECTORIES "${CMAKE_SOURCE_DIR}/src/zstd/lib"
+ IMPORTED_LOCATION "${CMAKE_CURRENT_BINARY_DIR}/libzstd/lib/libzstd.a")
+add_dependencies(zstd zstd_ext)
+
+set(zstd_sources
+ CompressionPluginZstd.cc
+)
+
+add_library(ceph_zstd SHARED ${zstd_sources})
+target_link_libraries(ceph_zstd PRIVATE zstd)
+set_target_properties(ceph_zstd PROPERTIES
+ VERSION 2.0.0
+ SOVERSION 2
+ INSTALL_RPATH "")
+install(TARGETS ceph_zstd DESTINATION ${compressor_plugin_dir})
diff --git a/src/compressor/zstd/CompressionPluginZstd.cc b/src/compressor/zstd/CompressionPluginZstd.cc
new file mode 100644
index 00000000..62c2cfbf
--- /dev/null
+++ b/src/compressor/zstd/CompressionPluginZstd.cc
@@ -0,0 +1,36 @@
+/*
+ * Ceph - scalable distributed file system
+ *
+ * Copyright (C) 2015 Mirantis, Inc.
+ *
+ * Author: Alyona Kiseleva <akiselyova@mirantis.com>
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ */
+
+#include "acconfig.h"
+#include "ceph_ver.h"
+#include "common/ceph_context.h"
+#include "CompressionPluginZstd.h"
+
+// -----------------------------------------------------------------------------
+
+const char *__ceph_plugin_version()
+{
+ return CEPH_GIT_NICE_VER;
+}
+
+// -----------------------------------------------------------------------------
+
+int __ceph_plugin_init(CephContext *cct,
+ const std::string& type,
+ const std::string& name)
+{
+ PluginRegistry *instance = cct->get_plugin_registry();
+
+ return instance->add(type, name, new CompressionPluginZstd(cct));
+}
diff --git a/src/compressor/zstd/CompressionPluginZstd.h b/src/compressor/zstd/CompressionPluginZstd.h
new file mode 100644
index 00000000..72ef9c45
--- /dev/null
+++ b/src/compressor/zstd/CompressionPluginZstd.h
@@ -0,0 +1,43 @@
+/*
+ * Ceph - scalable distributed file system
+ *
+ * Copyright (C) 2015 Mirantis, Inc.
+ *
+ * Author: Alyona Kiseleva <akiselyova@mirantis.com>
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ */
+
+#ifndef CEPH_COMPRESSION_PLUGIN_ZSTD_H
+#define CEPH_COMPRESSION_PLUGIN_ZSTD_H
+
+// -----------------------------------------------------------------------------
+#include "ceph_ver.h"
+#include "compressor/CompressionPlugin.h"
+#include "ZstdCompressor.h"
+// -----------------------------------------------------------------------------
+
+class CompressionPluginZstd : public CompressionPlugin {
+
+public:
+
+ explicit CompressionPluginZstd(CephContext* cct) : CompressionPlugin(cct)
+ {}
+
+ int factory(CompressorRef *cs,
+ std::ostream *ss) override
+ {
+ if (compressor == 0) {
+ ZstdCompressor *interface = new ZstdCompressor(cct);
+ compressor = CompressorRef(interface);
+ }
+ *cs = compressor;
+ return 0;
+ }
+};
+
+#endif
diff --git a/src/compressor/zstd/ZstdCompressor.h b/src/compressor/zstd/ZstdCompressor.h
new file mode 100644
index 00000000..83508b93
--- /dev/null
+++ b/src/compressor/zstd/ZstdCompressor.h
@@ -0,0 +1,106 @@
+// -*- mode:C++; tab-width:8; c-basic-offset:2; indent-tabs-mode:t -*-
+// vim: ts=8 sw=2 smarttab
+/*
+ * Ceph - scalable distributed file system
+ *
+ * Copyright (C) 2015 Haomai Wang <haomaiwang@gmail.com>
+ *
+ * This is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License version 2.1, as published by the Free Software
+ * Foundation. See file COPYING.
+ *
+ */
+
+#ifndef CEPH_ZSTDCOMPRESSOR_H
+#define CEPH_ZSTDCOMPRESSOR_H
+
+#define ZSTD_STATIC_LINKING_ONLY
+#include "zstd/lib/zstd.h"
+
+#include "include/buffer.h"
+#include "include/encoding.h"
+#include "compressor/Compressor.h"
+
+class ZstdCompressor : public Compressor {
+ public:
+ ZstdCompressor(CephContext *cct) : Compressor(COMP_ALG_ZSTD, "zstd"), cct(cct) {}
+
+ int compress(const bufferlist &src, bufferlist &dst) override {
+ ZSTD_CStream *s = ZSTD_createCStream();
+ ZSTD_initCStream_srcSize(s, cct->_conf->compressor_zstd_level, src.length());
+ auto p = src.begin();
+ size_t left = src.length();
+
+ size_t const out_max = ZSTD_compressBound(left);
+ bufferptr outptr = buffer::create_small_page_aligned(out_max);
+ ZSTD_outBuffer_s outbuf;
+ outbuf.dst = outptr.c_str();
+ outbuf.size = outptr.length();
+ outbuf.pos = 0;
+
+ while (left) {
+ ceph_assert(!p.end());
+ struct ZSTD_inBuffer_s inbuf;
+ inbuf.pos = 0;
+ inbuf.size = p.get_ptr_and_advance(left, (const char**)&inbuf.src);
+ left -= inbuf.size;
+ ZSTD_EndDirective const zed = (left==0) ? ZSTD_e_end : ZSTD_e_continue;
+ size_t r = ZSTD_compress_generic(s, &outbuf, &inbuf, zed);
+ if (ZSTD_isError(r)) {
+ return -EINVAL;
+ }
+ }
+ ceph_assert(p.end());
+
+ ZSTD_freeCStream(s);
+
+ // prefix with decompressed length
+ encode((uint32_t)src.length(), dst);
+ dst.append(outptr, 0, outbuf.pos);
+ return 0;
+ }
+
+ int decompress(const bufferlist &src, bufferlist &dst) override {
+ auto i = std::cbegin(src);
+ return decompress(i, src.length(), dst);
+ }
+
+ int decompress(bufferlist::const_iterator &p,
+ size_t compressed_len,
+ bufferlist &dst) override {
+ if (compressed_len < 4) {
+ return -1;
+ }
+ compressed_len -= 4;
+ uint32_t dst_len;
+ decode(dst_len, p);
+
+ bufferptr dstptr(dst_len);
+ ZSTD_outBuffer_s outbuf;
+ outbuf.dst = dstptr.c_str();
+ outbuf.size = dstptr.length();
+ outbuf.pos = 0;
+ ZSTD_DStream *s = ZSTD_createDStream();
+ ZSTD_initDStream(s);
+ while (compressed_len > 0) {
+ if (p.end()) {
+ return -1;
+ }
+ ZSTD_inBuffer_s inbuf;
+ inbuf.pos = 0;
+ inbuf.size = p.get_ptr_and_advance(compressed_len,
+ (const char**)&inbuf.src);
+ ZSTD_decompressStream(s, &outbuf, &inbuf);
+ compressed_len -= inbuf.size;
+ }
+ ZSTD_freeDStream(s);
+
+ dst.append(dstptr, 0, outbuf.pos);
+ return 0;
+ }
+ private:
+ CephContext *const cct;
+};
+
+#endif