summaryrefslogtreecommitdiffstats
path: root/src/ocf/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/ocf/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/ocf/CMakeLists.txt')
-rw-r--r--src/ocf/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/ocf/CMakeLists.txt b/src/ocf/CMakeLists.txt
new file mode 100644
index 00000000..9a87d02f
--- /dev/null
+++ b/src/ocf/CMakeLists.txt
@@ -0,0 +1,10 @@
+# The root of the OCF resource agent hierarchy
+# Per the OCF standard, it's always "lib",
+# not "lib64" (even on 64-bit platforms).
+set(ocf_dir ${CMAKE_INSTALL_PREFIX}/lib/ocf)
+
+# The ceph provider directory
+set(ra_dir ${ocf_dir}/resource.d/${PROJECT_NAME})
+
+configure_file(rbd.in rbd @ONLY)
+install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/rbd DESTINATION ${ra_dir})