summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/dashboard/frontend/package.json
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/pybind/mgr/dashboard/frontend/package.json
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pybind/mgr/dashboard/frontend/package.json')
-rw-r--r--src/pybind/mgr/dashboard/frontend/package.json139
1 files changed, 139 insertions, 0 deletions
diff --git a/src/pybind/mgr/dashboard/frontend/package.json b/src/pybind/mgr/dashboard/frontend/package.json
new file mode 100644
index 00000000..7e8ed52f
--- /dev/null
+++ b/src/pybind/mgr/dashboard/frontend/package.json
@@ -0,0 +1,139 @@
+{
+ "name": "ceph-dashboard",
+ "version": "0.0.0",
+ "license": "MIT",
+ "config": {
+ "locale": "en-US"
+ },
+ "scripts": {
+ "ng": "ng",
+ "start": "npm run env_build && ng serve --host 0.0.0.0 --ssl",
+ "build": "export _locale=${LOCALE:-$npm_package_config_locale}; if [ ${_locale} = $npm_package_config_locale ]; then export _file=; else export _file=src/locale/messages.${_locale}.xlf; fi; ng build --outputPath=dist/${_locale} --i18nFile=${_file} --i18nLocale=${_locale}",
+ "prebuild": "npm run env_build",
+ "build:en-US": "LOCALE=en-US npm run build",
+ "build:de-DE": "LOCALE=de-DE npm run build",
+ "build:es-ES": "LOCALE=es-ES npm run build",
+ "build:pt-BR": "LOCALE=pt-BR npm run build",
+ "build:it-IT": "LOCALE=it-IT npm run build",
+ "build:cs": "LOCALE=cs npm run build",
+ "build:fr-FR": "LOCALE=fr-FR npm run build",
+ "build:id-ID": "LOCALE=id-ID npm run build",
+ "build:ja-JP": "LOCALE=ja-JP npm run build",
+ "build:pl-PL": "LOCALE=pl-PL npm run build",
+ "build:zh-CN": "LOCALE=zh-CN npm run build",
+ "build:zh-TW": "LOCALE=zh-TW npm run build",
+ "env_build": "cp src/environments/environment.tpl.ts src/environments/environment.prod.ts && cp src/environments/environment.tpl.ts src/environments/environment.ts && node ./environment.build.js",
+ "i18n": "npm run i18n:extract && npm run i18n:push && npm run i18n:pull && npm run i18n:merge",
+ "i18n:extract": "ng xi18n --i18n-format xlf --i18n-locale en-US --output-path locale --progress=false && ngx-extractor -i 'src/**/*.ts' -f xlf -o src/locale/messages.xlf -l en-US",
+ "i18n:push": "npx i18ntool push -c i18n.config.json",
+ "i18n:pull": "npx i18ntool pull -c i18n.config.json",
+ "i18n:merge": "npx i18ntool merge -c i18n.config.json",
+ "i18n:token": "npx i18ntool config token",
+ "test": "npm run test:config && jest --watch",
+ "test:ci": "npm run test:config && JEST_SILENT_REPORTER_DOTS=true jest --coverage --reporters jest-silent-reporter",
+ "test:config": "if [ ! -e 'src/unit-test-configuration.ts' ]; then cp 'src/unit-test-configuration.ts.sample' 'src/unit-test-configuration.ts'; fi",
+ "e2e": "npm run env_build && npm run e2e:update && ng e2e --webdriverUpdate=false",
+ "e2e:dev": "npm run env_build && npm run e2e:update && ng e2e --dev-server-target --webdriverUpdate=false",
+ "e2e:update": "npx webdriver-manager update --ignore_ssl --gecko=false --versions.chrome=$(google-chrome --version | awk '{ print $3 }')",
+ "lint:tslint": "ng lint",
+ "lint:prettier": "prettier --list-different \"{src,e2e}/**/*.{ts,scss}\"",
+ "lint:html": "html-linter --config html-linter.config.json",
+ "lint:tsc": "npm run test:config && tsc -p src/tsconfig.app.json --noEmit --noUnusedLocals --noUnusedParameters && tsc -p src/tsconfig.spec.json --noEmit --noUnusedLocals --noUnusedParameters && tsc -p e2e/tsconfig.e2e.json --noEmit --noUnusedLocals --noUnusedParameters",
+ "lint": "npm run lint:tsc && npm run lint:tslint && npm run lint:prettier && npm run lint:html",
+ "fix:prettier": "prettier --write \"{src,e2e}/**/*.{ts,scss}\"",
+ "fix:tslint": "npm run lint:tslint -- --fix",
+ "fixmod": "prettier --write $(git rev-parse --show-toplevel)/$(git status --porcelain | grep -E '^(\\sM|\\?\\?|A)' | sed -e 's/^...//' | grep -E '^(src|e2e).*\\.(ts|scss)$') 1>/dev/null 2>&1 && echo 'done' || echo 'no changes found'",
+ "fix": "npm run fix:tslint; npm run fix:prettier",
+ "compodoc": "compodoc",
+ "doc-build": "compodoc -p src/tsconfig.app.json",
+ "doc-serve": "compodoc --port 8444 -s src/tsconfig.app.json"
+ },
+ "private": true,
+ "jest": {
+ "preset": "jest-preset-angular",
+ "setupFilesAfterEnv": [
+ "<rootDir>/src/setupJest.ts"
+ ],
+ "transformIgnorePatterns": [
+ "node_modules/(?!@ngrx|ngx-bootstrap|@progress)"
+ ],
+ "transform": {
+ "^.+\\.(ts|html)$": "<rootDir>/node_modules/jest-preset-angular/preprocessor.js",
+ "^.+\\.js$": "babel-jest"
+ },
+ "setupFiles": [
+ "jest-canvas-mock"
+ ],
+ "coverageReporters": [
+ "cobertura",
+ "html"
+ ],
+ "modulePathIgnorePatterns": [
+ "<rootDir>/coverage/"
+ ],
+ "testMatch": [
+ "**/*.spec.ts"
+ ],
+ "testURL": "http://localhost/"
+ },
+ "dependencies": {
+ "@angular/animations": "7.2.6",
+ "@angular/common": "7.2.6",
+ "@angular/compiler": "7.2.6",
+ "@angular/core": "7.2.6",
+ "@angular/forms": "7.2.6",
+ "@angular/http": "7.2.6",
+ "@angular/platform-browser": "7.2.6",
+ "@angular/platform-browser-dynamic": "7.2.6",
+ "@angular/router": "7.2.6",
+ "@ngx-translate/i18n-polyfill": "1.0.0",
+ "@swimlane/ngx-datatable": "14.0.0",
+ "awesome-bootstrap-checkbox": "0.3.7",
+ "bootstrap": "3.4.1",
+ "chart.js": "2.7.3",
+ "core-js": "2.6.5",
+ "detect-browser": "4.1.0",
+ "fork-awesome": "1.1.6",
+ "lodash": "4.17.14",
+ "moment": "2.24.0",
+ "ng-block-ui": "2.1.1",
+ "ng2-charts": "1.6.0",
+ "ng2-tree": "2.0.0-rc.11",
+ "ngx-bootstrap": "5.1.0",
+ "ngx-toastr": "10.0.4",
+ "rxjs": "6.5.2",
+ "rxjs-compat": "6.5.2",
+ "swagger-ui-dist": "3.23.10",
+ "tslib": "1.9.3",
+ "zone.js": "0.8.29"
+ },
+ "devDependencies": {
+ "@angular-devkit/build-angular": "0.13.9",
+ "@angular/cli": "7.3.3",
+ "@angular/compiler-cli": "7.2.6",
+ "@angular/language-service": "7.2.6",
+ "@compodoc/compodoc": "1.1.10",
+ "@types/jasmine": "3.3.9",
+ "@types/jasminewd2": "2.0.6",
+ "@types/jest": "24.0.9",
+ "@types/lodash": "4.14.121",
+ "@types/node": "11.9.5",
+ "babel-preset-env": "1.7.0",
+ "codelyzer": "4.5.0",
+ "html-linter": "1.1.1",
+ "jasmine-core": "3.3.0",
+ "jasmine-spec-reporter": "4.2.1",
+ "jest": "24.8.0",
+ "jest-canvas-mock": "1.1.0",
+ "jest-preset-angular": "6.0.2",
+ "jest-silent-reporter": "0.1.2",
+ "prettier": "1.16.4",
+ "npm-run-all": "^4.1.5",
+ "protractor": "5.4.2",
+ "replace-in-file": "3.4.3",
+ "transifex-i18ntool": "1.1.0",
+ "ts-node": "8.0.2",
+ "tslint": "5.18.0",
+ "typescript": "3.2.4"
+ }
+}