summaryrefslogtreecommitdiffstats
path: root/src/seastar/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/seastar/tests/CMakeLists.txt
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/seastar/tests/CMakeLists.txt')
-rw-r--r--src/seastar/tests/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/seastar/tests/CMakeLists.txt b/src/seastar/tests/CMakeLists.txt
new file mode 100644
index 00000000..1fe24ce6
--- /dev/null
+++ b/src/seastar/tests/CMakeLists.txt
@@ -0,0 +1,44 @@
+#
+# This file is open source software, licensed to you under the terms
+# of the Apache License, Version 2.0 (the "License"). See the NOTICE file
+# distributed with this work for additional information regarding copyright
+# ownership. You may not use this file except in compliance with the License.
+#
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+#
+# Copyright (C) 2018 Scylladb, Ltd.
+#
+
+function (seastar_jenkins_arguments test_name var)
+ string (TOLOWER ${CMAKE_BUILD_TYPE} mode)
+ set (output_file "${CMAKE_SOURCE_DIR}/${Seastar_JENKINS}.${mode}.${test_name}_test.boost.xml")
+
+ set (${var}
+ --output_format=XML
+ --log_level=all
+ --report_level=no
+ --log_sink=${output_file}
+ PARENT_SCOPE)
+endfunction ()
+
+# Distribution tests.
+if (Seastar_INSTALL)
+ add_subdirectory (dist)
+endif ()
+
+# Performance tests.
+add_subdirectory (perf)
+
+# Unit tests.
+add_subdirectory (unit)