summaryrefslogtreecommitdiffstats
path: root/src/spdk/doc/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/spdk/doc/Makefile
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/doc/Makefile')
-rw-r--r--src/spdk/doc/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/spdk/doc/Makefile b/src/spdk/doc/Makefile
new file mode 100644
index 00000000..ec3f396d
--- /dev/null
+++ b/src/spdk/doc/Makefile
@@ -0,0 +1,23 @@
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+
+all: doc
+ @:
+
+.PHONY: all doc clean
+
+doc: output
+
+changelog.md: ../CHANGELOG.md
+ $(Q)sed -e 's/^# Changelog/# Changelog {#changelog}/' \
+ -e 's/^##/#/' \
+ -e 's/^# \(\(v..\...\):.*\)/# \1 {#changelog-\2}/' \
+ -e '/# v..\...:/s/\./-/2' \
+ < $< > $@
+
+output: Doxyfile changelog.md $(wildcard *.md) $(wildcard ../include/spdk/*.h)
+ $(Q)rm -rf $@
+ $(Q)doxygen Doxyfile
+
+clean:
+ $(Q)rm -rf output changelog.md