summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/ipsec-secgw/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/spdk/dpdk/examples/ipsec-secgw/meson.build
parentInitial commit. (diff)
downloadceph-upstream.tar.xz
ceph-upstream.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/dpdk/examples/ipsec-secgw/meson.build')
-rw-r--r--src/spdk/dpdk/examples/ipsec-secgw/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/ipsec-secgw/meson.build b/src/spdk/dpdk/examples/ipsec-secgw/meson.build
new file mode 100644
index 00000000..77d8b298
--- /dev/null
+++ b/src/spdk/dpdk/examples/ipsec-secgw/meson.build
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+# meson file, for building this example as part of a main DPDK build.
+#
+# To build this example as a standalone application with an already-installed
+# DPDK instance, use 'make'
+
+deps += ['security', 'lpm', 'acl', 'hash']
+allow_experimental_apis = true
+sources = files(
+ 'esp.c', 'ipsec.c', 'ipsec-secgw.c', 'parser.c',
+ 'rt.c', 'sa.c', 'sp4.c', 'sp6.c'
+)