summaryrefslogtreecommitdiffstats
path: root/src/spdk/shared_lib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/spdk/shared_lib
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/shared_lib')
-rw-r--r--src/spdk/shared_lib/Makefile65
-rw-r--r--src/spdk/shared_lib/spdk.map15
2 files changed, 80 insertions, 0 deletions
diff --git a/src/spdk/shared_lib/Makefile b/src/spdk/shared_lib/Makefile
new file mode 100644
index 00000000..6be95103
--- /dev/null
+++ b/src/spdk/shared_lib/Makefile
@@ -0,0 +1,65 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.modules.mk
+
+# Build combined libspdk.so shared library
+SHARED_LINKED_LIB := $(SPDK_ROOT_DIR)/build/lib/libspdk.so
+SHARED_REALNAME_LIB := $(SHARED_LINKED_LIB).$(SO_SUFFIX_ALL)
+IGNORED_LIBS := libspdk.so
+IGNORED_LIBS += libspdk_spdk_mock.so
+IGNORED_LIBS += libspdk_env_dpdk.so
+
+SPDK_SHARED_LIBS := $(filter-out $(IGNORED_LIBS), $(sort $(notdir $(wildcard $(SPDK_ROOT_DIR)/build/lib/*.so))))
+
+$(SHARED_REALNAME_LIB):
+ $(Q)echo " SO $(notdir $@)"; \
+ echo "GROUP ( AS_NEEDED ( $(SPDK_SHARED_LIBS) ) )" > $(SHARED_REALNAME_LIB)
+
+$(SHARED_LINKED_LIB) : $(SHARED_REALNAME_LIB)
+ $(Q)echo " SYMLINK $(notdir $@)"; $(BUILD_LINKERNAME_LIB)
+
+.PHONY: all clean $(DIRS-y)
+
+all: $(SHARED_LINKED_LIB)
+
+clean:
+ $(CLEAN_C) $(SHARED_REALNAME_LIB) $(SHARED_LINKED_LIB)
+
+install:
+ $(INSTALL_SHARED_LIB)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.subdirs.mk
diff --git a/src/spdk/shared_lib/spdk.map b/src/spdk/shared_lib/spdk.map
new file mode 100644
index 00000000..ac7ac270
--- /dev/null
+++ b/src/spdk/shared_lib/spdk.map
@@ -0,0 +1,15 @@
+{
+ global:
+
+ spdk_*;
+ rte_vhost_*;
+ virt*;
+ SPDK_LOG*;
+ g_subsystems;
+ g_subsystems_deps;
+ g_spdk_iscsi_opts;
+ _spdk_trace_record;
+ g_trace_histories;
+
+ local: *;
+};