summaryrefslogtreecommitdiffstats
path: root/src/spdk/test/blobfs/mkfs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/spdk/test/blobfs/mkfs
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/spdk/test/blobfs/mkfs')
-rw-r--r--src/spdk/test/blobfs/mkfs/.gitignore1
-rw-r--r--src/spdk/test/blobfs/mkfs/Makefile59
-rw-r--r--src/spdk/test/blobfs/mkfs/mkfs.c150
3 files changed, 210 insertions, 0 deletions
diff --git a/src/spdk/test/blobfs/mkfs/.gitignore b/src/spdk/test/blobfs/mkfs/.gitignore
new file mode 100644
index 00000000..54e292c6
--- /dev/null
+++ b/src/spdk/test/blobfs/mkfs/.gitignore
@@ -0,0 +1 @@
+mkfs
diff --git a/src/spdk/test/blobfs/mkfs/Makefile b/src/spdk/test/blobfs/mkfs/Makefile
new file mode 100644
index 00000000..8367571e
--- /dev/null
+++ b/src/spdk/test/blobfs/mkfs/Makefile
@@ -0,0 +1,59 @@
+#
+# BSD LICENSE
+#
+# Copyright (c) Intel Corporation.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in
+# the documentation and/or other materials provided with the
+# distribution.
+# * Neither the name of Intel Corporation nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+SPDK_ROOT_DIR := $(abspath $(CURDIR)/../../..)
+include $(SPDK_ROOT_DIR)/mk/spdk.common.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.app.mk
+include $(SPDK_ROOT_DIR)/mk/spdk.modules.mk
+
+APP = mkfs
+
+C_SRCS := mkfs.c
+
+SPDK_LIB_LIST = event_bdev event_copy
+SPDK_LIB_LIST += blobfs blob bdev blob_bdev copy event thread util conf trace \
+ log jsonrpc json rpc
+
+LIBS += $(COPY_MODULES_LINKER_ARGS) $(BLOCKDEV_MODULES_LINKER_ARGS) $(SOCK_MODULES_LINKER_ARGS)
+LIBS += $(SPDK_LIB_LINKER_ARGS) $(ENV_LINKER_ARGS)
+
+all : $(APP)
+ @:
+
+$(APP) : $(OBJS) $(SPDK_LIB_FILES) $(COPY_MODULES_FILES) $(BLOCKDEV_MODULES_FILES) $(SOCK_MODULES_FILES) $(ENV_LIBS)
+ $(LINK_C)
+
+clean :
+ $(CLEAN_C) $(APP)
+
+include $(SPDK_ROOT_DIR)/mk/spdk.deps.mk
diff --git a/src/spdk/test/blobfs/mkfs/mkfs.c b/src/spdk/test/blobfs/mkfs/mkfs.c
new file mode 100644
index 00000000..0bedd84a
--- /dev/null
+++ b/src/spdk/test/blobfs/mkfs/mkfs.c
@@ -0,0 +1,150 @@
+/*-
+ * BSD LICENSE
+ *
+ * Copyright (c) Intel Corporation.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * * Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * * Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in
+ * the documentation and/or other materials provided with the
+ * distribution.
+ * * Neither the name of Intel Corporation nor the names of its
+ * contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+ * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+ * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include "spdk/stdinc.h"
+
+#include "spdk/blobfs.h"
+#include "spdk/bdev.h"
+#include "spdk/event.h"
+#include "spdk/blob_bdev.h"
+#include "spdk/log.h"
+#include "spdk/string.h"
+
+struct spdk_bs_dev *g_bs_dev;
+const char *g_bdev_name;
+static uint64_t g_cluster_size;
+
+static void
+stop_cb(void *ctx, int fserrno)
+{
+ spdk_app_stop(0);
+}
+
+static void
+shutdown_cb(void *arg1, void *arg2)
+{
+ struct spdk_filesystem *fs = arg1;
+
+ printf("done.\n");
+ spdk_fs_unload(fs, stop_cb, NULL);
+}
+
+static void
+init_cb(void *ctx, struct spdk_filesystem *fs, int fserrno)
+{
+ struct spdk_event *event;
+
+ event = spdk_event_allocate(0, shutdown_cb, fs, NULL);
+ spdk_event_call(event);
+}
+
+static void
+spdk_mkfs_run(void *arg1, void *arg2)
+{
+ struct spdk_bdev *bdev;
+ struct spdk_blobfs_opts blobfs_opt;
+
+ bdev = spdk_bdev_get_by_name(g_bdev_name);
+
+ if (bdev == NULL) {
+ SPDK_ERRLOG("bdev %s not found\n", g_bdev_name);
+ spdk_app_stop(-1);
+ return;
+ }
+
+ printf("Initializing filesystem on bdev %s...", g_bdev_name);
+ fflush(stdout);
+
+ spdk_fs_opts_init(&blobfs_opt);
+ if (g_cluster_size) {
+ blobfs_opt.cluster_sz = g_cluster_size;
+ }
+ g_bs_dev = spdk_bdev_create_bs_dev(bdev, NULL, NULL);
+ if (blobfs_opt.cluster_sz) {
+ spdk_fs_init(g_bs_dev, &blobfs_opt, NULL, init_cb, NULL);
+ } else {
+ spdk_fs_init(g_bs_dev, NULL, NULL, init_cb, NULL);
+ }
+}
+
+static void
+mkfs_usage(void)
+{
+ printf(" -C <size> cluster size\n");
+}
+
+static void
+mkfs_parse_arg(int ch, char *arg)
+{
+ bool has_prefix;
+
+ switch (ch) {
+ case 'C':
+ spdk_parse_capacity(arg, &g_cluster_size, &has_prefix);
+ break;
+ default:
+ break;
+ }
+
+}
+
+int main(int argc, char **argv)
+{
+ struct spdk_app_opts opts = {};
+ int rc = 0;
+
+ if (argc < 3) {
+ SPDK_ERRLOG("usage: %s <conffile> <bdevname>\n", argv[0]);
+ exit(1);
+ }
+
+ spdk_app_opts_init(&opts);
+ opts.name = "spdk_mkfs";
+ opts.config_file = argv[1];
+ opts.reactor_mask = "0x3";
+ opts.mem_size = 1024;
+ opts.shutdown_cb = NULL;
+
+ spdk_fs_set_cache_size(512);
+ g_bdev_name = argv[2];
+ if ((rc = spdk_app_parse_args(argc, argv, &opts, "C:", NULL,
+ mkfs_parse_arg, mkfs_usage)) !=
+ SPDK_APP_PARSE_ARGS_SUCCESS) {
+ exit(rc);
+ }
+
+ rc = spdk_app_start(&opts, spdk_mkfs_run, NULL, NULL);
+ spdk_app_fini();
+
+ return rc;
+}