summaryrefslogtreecommitdiffstats
path: root/src/test/fedora-29
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 18:24:20 +0000
commit483eb2f56657e8e7f419ab1a4fab8dce9ade8609 (patch)
treee5d88d25d870d5dedacb6bbdbe2a966086a0a5cf /src/test/fedora-29
parentInitial commit. (diff)
downloadceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.tar.xz
ceph-483eb2f56657e8e7f419ab1a4fab8dce9ade8609.zip
Adding upstream version 14.2.21.upstream/14.2.21upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/fedora-29')
-rw-r--r--src/test/fedora-29/Dockerfile.in29
l---------src/test/fedora-29/ceph.spec.in1
l---------src/test/fedora-29/install-deps.sh1
3 files changed, 31 insertions, 0 deletions
diff --git a/src/test/fedora-29/Dockerfile.in b/src/test/fedora-29/Dockerfile.in
new file mode 100644
index 00000000..fbb88d86
--- /dev/null
+++ b/src/test/fedora-29/Dockerfile.in
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2015 Red Hat <contact@redhat.com>
+#
+# Author: Loic Dachary <loic@dachary.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Library Public License for more details.
+#
+# Environment variables are substituted via envsubst(1)
+#
+# user_id=$(id -u)
+# os_version= the desired REPOSITORY TAG
+#
+FROM fedora:%%os_version%%
+COPY install-deps.sh /root/
+COPY ceph.spec.in /root/
+# build dependencies
+RUN dnf install -y which ; cd /root ; ./install-deps.sh
+# development tools
+# nc is required to run make check on firefly only (giant+ do not use nc)
+RUN dnf install -y ccache valgrind gdb git python-virtualenv gdisk kpartx jq sudo xmlstarlet parted nc
+RUN if test %%USER%% != root ; then useradd -M --uid %%user_id%% %%USER%% && echo '%%USER%% ALL=(ALL) NOPASSWD:ALL' >> /etc/sudoers ; fi
diff --git a/src/test/fedora-29/ceph.spec.in b/src/test/fedora-29/ceph.spec.in
new file mode 120000
index 00000000..9abcafd1
--- /dev/null
+++ b/src/test/fedora-29/ceph.spec.in
@@ -0,0 +1 @@
+../../../ceph.spec.in \ No newline at end of file
diff --git a/src/test/fedora-29/install-deps.sh b/src/test/fedora-29/install-deps.sh
new file mode 120000
index 00000000..fc9c78b2
--- /dev/null
+++ b/src/test/fedora-29/install-deps.sh
@@ -0,0 +1 @@
+../../../install-deps.sh \ No newline at end of file