summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/config/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/config/test/CMakeLists.txt')
-rw-r--r--src/boost/libs/config/test/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/boost/libs/config/test/CMakeLists.txt b/src/boost/libs/config/test/CMakeLists.txt
new file mode 100644
index 00000000..96511ddd
--- /dev/null
+++ b/src/boost/libs/config/test/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright 2018 John Maddock
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+#
+# CAUTION!!!!
+#
+# This addition to Boost.Config should be considered experimental and is part
+# of an ongoing effort to add CMake support Boost-wide.
+#
+# IT IS HIGHLY LIKELY THAT THIS FILE WILL CHANGE WITHOUT NOTICE!!!
+#
+# DO NOT REPLY ON THE CONTENTS OF THIS FILE!!!
+#
+# In particular this is not a comprehensive test suite, just a quick check
+# that the root CMakeLists.txt works OK, and a convenience for folks who
+# want to import these projects into their IDE.
+#
+cmake_minimum_required(VERSION 3.5)
+
+add_subdirectory(.. ${CMAKE_CURRENT_BINARY_DIR}/boost_config)
+
+add_executable(config_info config_info.cpp)
+target_link_libraries(config_info Boost::config)
+
+add_executable(config_test config_test.cpp)
+target_link_libraries(config_test Boost::config)
+