summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/function/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/function/CMakeLists.txt')
-rw-r--r--src/boost/libs/function/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/boost/libs/function/CMakeLists.txt b/src/boost/libs/function/CMakeLists.txt
new file mode 100644
index 00000000..01de5f5a
--- /dev/null
+++ b/src/boost/libs/function/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright 2019 Peter Dimov
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt
+
+# Partial (add_subdirectory only) and experimental CMake support
+# Subject to change; please do not rely on the contents of this file yet
+
+cmake_minimum_required(VERSION 3.5)
+project(BoostFunction LANGUAGES CXX)
+
+add_library(boost_function INTERFACE)
+add_library(Boost::function ALIAS boost_function)
+
+target_include_directories(boost_function INTERFACE include)
+
+target_link_libraries(boost_function
+ INTERFACE
+ Boost::assert
+ Boost::bind
+ Boost::config
+ Boost::core
+ Boost::integer
+ Boost::preprocessor
+ Boost::throw_exception
+ Boost::type_index
+ Boost::type_traits
+ Boost::typeof
+)