summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/mp11/test/check_cmake_version.cpp
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/mp11/test/check_cmake_version.cpp')
-rw-r--r--src/boost/libs/mp11/test/check_cmake_version.cpp27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/boost/libs/mp11/test/check_cmake_version.cpp b/src/boost/libs/mp11/test/check_cmake_version.cpp
new file mode 100644
index 00000000..2fd46483
--- /dev/null
+++ b/src/boost/libs/mp11/test/check_cmake_version.cpp
@@ -0,0 +1,27 @@
+// Check whether the version in CMakeLists.txt is up to date
+//
+// Copyright 2018 Peter Dimov
+//
+// Distributed under the Boost Software License, Version 1.0.
+//
+// See accompanying file LICENSE_1_0.txt or copy at
+// http://www.boost.org/LICENSE_1_0.txt
+
+#include <boost/core/lightweight_test.hpp>
+#include <boost/version.hpp>
+#include <cstdio>
+
+int main( int ac, char const* av[] )
+{
+ BOOST_TEST_EQ( ac, 2 );
+
+ if( ac >= 2 )
+ {
+ char version[ 64 ];
+ std::sprintf( version, "%d.%d.%d", BOOST_VERSION / 100000, BOOST_VERSION / 100 % 1000, BOOST_VERSION % 100 );
+
+ BOOST_TEST_CSTR_EQ( av[1], version );
+ }
+
+ return boost::report_errors();
+}