summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/outcome/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/outcome/CMakeLists.txt')
-rw-r--r--src/boost/libs/outcome/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/boost/libs/outcome/CMakeLists.txt b/src/boost/libs/outcome/CMakeLists.txt
new file mode 100644
index 00000000..cc49eb71
--- /dev/null
+++ b/src/boost/libs/outcome/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+
+cmake_minimum_required(VERSION 3.5)
+project(BoostOutcome LANGUAGES CXX)
+
+add_library(boost_outcome INTERFACE)
+add_library(Boost::outcome ALIAS boost_outcome)
+
+target_include_directories(boost_outcome INTERFACE include)
+
+target_link_libraries(boost_outcome INTERFACE
+ Boost::config
+ Boost::exception
+ Boost::system
+)