summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/polygon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/polygon/CMakeLists.txt')
-rw-r--r--src/boost/libs/polygon/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/boost/libs/polygon/CMakeLists.txt b/src/boost/libs/polygon/CMakeLists.txt
new file mode 100644
index 00000000..931f58a1
--- /dev/null
+++ b/src/boost/libs/polygon/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright 2018 Glen Joseph Fernandes
+# (glenjofe@gmail.com)
+#
+# Distributed under the Boost Software License, Version 1.0.
+# (http://www.boost.org/LICENSE_1_0.txt)
+
+cmake_minimum_required(VERSION 3.5)
+
+project(BoostPolygon LANGUAGES CXX)
+
+add_library(boost_polygon INTERFACE)
+
+add_library(Boost::polygon ALIAS boost_polygon)
+
+target_include_directories(boost_polygon INTERFACE include)
+
+target_link_libraries(boost_polygon INTERFACE Boost::config)