summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/regex/test/profile
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/regex/test/profile')
-rw-r--r--src/boost/libs/regex/test/profile/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/boost/libs/regex/test/profile/Makefile b/src/boost/libs/regex/test/profile/Makefile
new file mode 100644
index 00000000..f1b3def7
--- /dev/null
+++ b/src/boost/libs/regex/test/profile/Makefile
@@ -0,0 +1,16 @@
+# copyright John Maddock 2003
+# Distributed under the Boost Software License, Version 1.0.
+# (See accompanying file LICENSE_1_0.txt or copy at
+# http://www.boost.org/LICENSE_1_0.txt.
+
+
+regress :
+ g++ -fprofile-arcs -ftest-coverage -DBOOST_REGEX_RECURSIVE -DBOOST_REGEX_BLOCKSIZE=512 -DBOOST_REGEX_MAX_CACHE_BLOCKS=0 -DBOOST_REGEX_MATCH_EXTRA -g -I../../../../ -o regress ../regress/*.cpp ../../src/*.cpp ../../../test/src/ex*.cpp ../../../test/src/cpp_main.cpp
+ ./regress
+ gcov basic_tests.cpp
+
+
+
+
+
+