summaryrefslogtreecommitdiffstats
path: root/src/boost/libs/winapi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/boost/libs/winapi/CMakeLists.txt')
-rw-r--r--src/boost/libs/winapi/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/boost/libs/winapi/CMakeLists.txt b/src/boost/libs/winapi/CMakeLists.txt
new file mode 100644
index 00000000..556939f1
--- /dev/null
+++ b/src/boost/libs/winapi/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright 2018 Peter Dimov
+# Copyright 2018 Andrey Semashev
+# Distributed under the Boost Software License, Version 1.0.
+# See accompanying file LICENSE_1_0.txt or copy at https://www.boost.org/LICENSE_1_0.txt
+
+# Partial (add_subdirectory only) and experimental CMake support
+# Subject to change; please do not rely on the contents of this file yet.
+
+cmake_minimum_required(VERSION 3.5)
+
+project(BoostWinAPI LANGUAGES CXX)
+
+add_library(boost_winapi INTERFACE)
+add_library(Boost::winapi ALIAS boost_winapi)
+
+target_include_directories(boost_winapi INTERFACE include)
+
+target_link_libraries(boost_winapi
+ INTERFACE
+ Boost::config
+ Boost::predef
+)