summaryrefslogtreecommitdiffstats
path: root/src/mon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/mon/CMakeLists.txt')
-rw-r--r--src/mon/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/mon/CMakeLists.txt b/src/mon/CMakeLists.txt
new file mode 100644
index 00000000..8172dfd9
--- /dev/null
+++ b/src/mon/CMakeLists.txt
@@ -0,0 +1,35 @@
+set(lib_mon_srcs
+ ${CMAKE_SOURCE_DIR}/src/auth/cephx/CephxKeyServer.cc
+ ${CMAKE_SOURCE_DIR}/src/auth/cephx/CephxServiceHandler.cc
+ ${CMAKE_SOURCE_DIR}/src/auth/AuthServiceHandler.cc
+ ${osd_mon_files}
+ Paxos.cc
+ PaxosService.cc
+ OSDMonitor.cc
+ MDSMonitor.cc
+ CommandHandler.cc
+ FSCommands.cc
+ MgrMonitor.cc
+ MgrStatMonitor.cc
+ Monitor.cc
+ MonmapMonitor.cc
+ LogMonitor.cc
+ AuthMonitor.cc
+ ConfigMap.cc
+ ConfigMonitor.cc
+ Elector.cc
+ HealthMonitor.cc
+ ConfigKeyService.cc
+ ../mds/MDSAuthCaps.cc
+ ../mgr/mgr_commands.cc
+ ../osd/OSDCap.cc
+ $<TARGET_OBJECTS:mgr_cap_obj>)
+
+if(HAVE_GSSAPI)
+ list(APPEND lib_mon_srcs
+ ${CMAKE_SOURCE_DIR}/src/auth/krb/KrbServiceHandler.cpp)
+endif()
+
+add_library(mon STATIC
+ ${lib_mon_srcs})
+target_link_libraries(mon kv heap_profiler)