summaryrefslogtreecommitdiffstats
path: root/src/pybind/mgr/insights/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/mgr/insights/CMakeLists.txt')
-rw-r--r--src/pybind/mgr/insights/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/pybind/mgr/insights/CMakeLists.txt b/src/pybind/mgr/insights/CMakeLists.txt
new file mode 100644
index 00000000..00722a99
--- /dev/null
+++ b/src/pybind/mgr/insights/CMakeLists.txt
@@ -0,0 +1,7 @@
+set(MGR_INSIGHTS_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/mgr-insights-virtualenv)
+
+add_custom_target(mgr-insights-test-venv
+ COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${MGR_PYTHON_EXECUTABLE} ${MGR_INSIGHTS_VIRTUALENV}
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/pybind/mgr/insights
+ COMMENT "insights tests virtualenv is being created")
+add_dependencies(tests mgr-insights-test-venv)