summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/ethtool/lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/examples/ethtool/lib/Makefile')
-rw-r--r--src/spdk/dpdk/examples/ethtool/lib/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/ethtool/lib/Makefile b/src/spdk/dpdk/examples/ethtool/lib/Makefile
new file mode 100644
index 00000000..6eaa640b
--- /dev/null
+++ b/src/spdk/dpdk/examples/ethtool/lib/Makefile
@@ -0,0 +1,37 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2015 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, can be overwritten by command line or environment
+RTE_TARGET ?= x86_64-native-linuxapp-gcc
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+ifneq ($(CONFIG_RTE_EXEC_ENV_LINUXAPP),y)
+$(error This application can only operate in a linuxapp environment, \
+please change the definition of the RTE_TARGET environment variable)
+endif
+
+# library name
+LIB = librte_ethtool.a
+
+LIBABIVER := 1
+
+# all source are stored in SRC-Y
+SRCS-y := rte_ethtool.c
+
+CFLAGS += -O3
+CFLAGS += $(WERROR_FLAGS)
+CFLAGS += -DALLOW_EXPERIMENTAL_API
+
+ifeq ($(CONFIG_RTE_BUILD_SHARED_LIB),y)
+ifeq ($(CONFIG_RTE_LIBRTE_IXGBE_PMD),y)
+LDLIBS += -lrte_pmd_ixgbe
+endif
+endif
+LDLIBS += -lrte_eal -lrte_ethdev
+
+include $(RTE_SDK)/mk/rte.extlib.mk