summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/ip_pipeline/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/examples/ip_pipeline/meson.build')
-rw-r--r--src/spdk/dpdk/examples/ip_pipeline/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/ip_pipeline/meson.build b/src/spdk/dpdk/examples/ip_pipeline/meson.build
new file mode 100644
index 00000000..a9f2ea44
--- /dev/null
+++ b/src/spdk/dpdk/examples/ip_pipeline/meson.build
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017-2018 Intel Corporation
+
+# meson file, for building this example as part of a main DPDK build.
+#
+# To build this example as a standalone application with an already-installed
+# DPDK instance, use 'make'
+
+deps += ['pipeline', 'bus_pci']
+allow_experimental_apis = true
+sources = files(
+ 'action.c',
+ 'cli.c',
+ 'conn.c',
+ 'kni.c',
+ 'link.c',
+ 'main.c',
+ 'mempool.c',
+ 'parser.c',
+ 'pipeline.c',
+ 'swq.c',
+ 'tap.c',
+ 'thread.c',
+ 'tmgr.c'
+)