summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/quota_watermark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/examples/quota_watermark/Makefile')
-rw-r--r--src/spdk/dpdk/examples/quota_watermark/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/quota_watermark/Makefile b/src/spdk/dpdk/examples/quota_watermark/Makefile
new file mode 100644
index 00000000..a37b8662
--- /dev/null
+++ b/src/spdk/dpdk/examples/quota_watermark/Makefile
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, can be overridden by command line or environment
+RTE_TARGET ?= x86_64-native-linuxapp-gcc
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+DIRS-$(CONFIG_RTE_EXEC_ENV_LINUXAPP) += qw
+DIRS-$(CONFIG_RTE_EXEC_ENV_LINUXAPP) += qwctl
+
+include $(RTE_SDK)/mk/rte.extsubdir.mk