summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/examples/quota_watermark/qwctl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/examples/quota_watermark/qwctl/Makefile')
-rw-r--r--src/spdk/dpdk/examples/quota_watermark/qwctl/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/spdk/dpdk/examples/quota_watermark/qwctl/Makefile b/src/spdk/dpdk/examples/quota_watermark/qwctl/Makefile
new file mode 100644
index 00000000..b390128e
--- /dev/null
+++ b/src/spdk/dpdk/examples/quota_watermark/qwctl/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+ifeq ($(RTE_SDK),)
+$(error "Please define RTE_SDK environment variable")
+endif
+
+# Default target, can be overridden by command line or environment
+RTE_TARGET ?= x86_64-native-linuxapp-gcc
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+# binary name
+APP = qwctl
+
+# all source are stored in SRCS-y
+SRCS-y := commands.c qwctl.c
+
+CFLAGS += -O3
+CFLAGS += $(WERROR_FLAGS)
+
+include $(RTE_SDK)/mk/rte.extapp.mk