summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/lib/librte_mbuf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/lib/librte_mbuf/Makefile')
-rw-r--r--src/spdk/dpdk/lib/librte_mbuf/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/spdk/dpdk/lib/librte_mbuf/Makefile b/src/spdk/dpdk/lib/librte_mbuf/Makefile
new file mode 100644
index 00000000..e2b98a25
--- /dev/null
+++ b/src/spdk/dpdk/lib/librte_mbuf/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+include $(RTE_SDK)/mk/rte.vars.mk
+
+# library name
+LIB = librte_mbuf.a
+
+CFLAGS += $(WERROR_FLAGS) -I$(SRCDIR) -O3
+LDLIBS += -lrte_eal -lrte_mempool
+
+EXPORT_MAP := rte_mbuf_version.map
+
+LIBABIVER := 4
+
+# all source are stored in SRCS-y
+SRCS-$(CONFIG_RTE_LIBRTE_MBUF) := rte_mbuf.c rte_mbuf_ptype.c rte_mbuf_pool_ops.c
+
+# install includes
+SYMLINK-$(CONFIG_RTE_LIBRTE_MBUF)-include := rte_mbuf.h rte_mbuf_ptype.h rte_mbuf_pool_ops.h
+
+include $(RTE_SDK)/mk/rte.lib.mk