summaryrefslogtreecommitdiffstats
path: root/src/spdk/dpdk/mk/toolchain/icc
diff options
context:
space:
mode:
Diffstat (limited to 'src/spdk/dpdk/mk/toolchain/icc')
-rw-r--r--src/spdk/dpdk/mk/toolchain/icc/rte.toolchain-compat.mk58
-rw-r--r--src/spdk/dpdk/mk/toolchain/icc/rte.vars.mk58
2 files changed, 116 insertions, 0 deletions
diff --git a/src/spdk/dpdk/mk/toolchain/icc/rte.toolchain-compat.mk b/src/spdk/dpdk/mk/toolchain/icc/rte.toolchain-compat.mk
new file mode 100644
index 00000000..2d663b34
--- /dev/null
+++ b/src/spdk/dpdk/mk/toolchain/icc/rte.toolchain-compat.mk
@@ -0,0 +1,58 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+#
+# CPUID-related options
+#
+# This was added to support compiler versions which might not support all the
+# flags we need
+#
+
+# find out ICC version
+
+ICC_MAJOR_VERSION = $(shell icc -dumpversion | cut -f1 -d.)
+
+ifeq ($(shell test $(ICC_MAJOR_VERSION) -lt 12 && echo 1), 1)
+ MACHINE_CFLAGS = -xSSE4.2
+$(warning You are not using ICC 12.x or higher. This is neither supported, nor tested.)
+
+else
+# proceed to adjust compiler flags
+
+ ICC_MINOR_VERSION = $(shell icc -dumpversion | cut -f2 -d.)
+
+# replace GCC flags with ICC flags
+ # if icc version >= 12
+ ifeq ($(shell test $(ICC_MAJOR_VERSION) -ge 12 && echo 1), 1)
+ # Atom
+ MACHINE_CFLAGS := $(patsubst -march=atom,-xSSSE3_ATOM -march=atom,$(MACHINE_CFLAGS))
+ # nehalem/westmere
+ MACHINE_CFLAGS := $(patsubst -march=corei7,-xSSE4.2 -march=corei7,$(MACHINE_CFLAGS))
+ # sandy bridge
+ MACHINE_CFLAGS := $(patsubst -march=corei7-avx,-xAVX,$(MACHINE_CFLAGS))
+ # ivy bridge
+ MACHINE_CFLAGS := $(patsubst -march=core-avx-i,-xCORE-AVX-I,$(MACHINE_CFLAGS))
+ # hsw
+ MACHINE_CFLAGS := $(patsubst -march=core-avx2,-xCORE-AVX2,$(MACHINE_CFLAGS))
+ # remove westmere flags
+ MACHINE_CFLAGS := $(filter-out -mpclmul -maes,$(MACHINE_CFLAGS))
+ endif
+ # if icc version == 12.0
+ ifeq ($(shell test $(ICC_MAJOR_VERSION) -eq 12 && test $(ICC_MINOR_VERSION) -eq 0 && echo 1), 1)
+ # Atom
+ MACHINE_CFLAGS := $(patsubst -xSSSE3_ATOM,-xSSE3_ATOM,$(MACHINE_CFLAGS))
+ # remove march options
+ MACHINE_CFLAGS := $(patsubst -march=%,-xSSE3,$(MACHINE_CFLAGS))
+ endif
+
+ # Disable thunderx PMD for icc <= 16.0
+ ifeq ($(shell test $(ICC_MAJOR_VERSION) -le 16 && echo 1), 1)
+ CONFIG_RTE_LIBRTE_THUNDERX_NICVF_PMD=d
+ endif
+
+ # Disable event/opdl PMD for icc <= 16.0
+ ifeq ($(shell test $(ICC_MAJOR_VERSION) -le 16 && echo 1), 1)
+ CONFIG_RTE_LIBRTE_PMD_OPDL_EVENTDEV=d
+ endif
+
+endif
diff --git a/src/spdk/dpdk/mk/toolchain/icc/rte.vars.mk b/src/spdk/dpdk/mk/toolchain/icc/rte.vars.mk
new file mode 100644
index 00000000..aa1422bf
--- /dev/null
+++ b/src/spdk/dpdk/mk/toolchain/icc/rte.vars.mk
@@ -0,0 +1,58 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2010-2014 Intel Corporation
+
+#
+# toolchain:
+#
+# - define CC, LD, AR, AS, ... (overridden by cmdline value)
+# - define TOOLCHAIN_CFLAGS variable (overridden by cmdline value)
+# - define TOOLCHAIN_LDFLAGS variable (overridden by cmdline value)
+# - define TOOLCHAIN_ASFLAGS variable (overridden by cmdline value)
+#
+
+# Warning: we do not use CROSS environment variable as icc is mainly a
+# x86->x86 compiler
+
+CC = icc
+KERNELCC = gcc
+CPP = cpp
+AS = nasm
+AR = ar
+LD = ld
+OBJCOPY = objcopy
+OBJDUMP = objdump
+STRIP = strip
+READELF = readelf
+
+ifeq ($(KERNELRELEASE),)
+HOSTCC = icc
+else
+HOSTCC = gcc
+endif
+HOSTAS = as
+
+TOOLCHAIN_CFLAGS =
+TOOLCHAIN_LDFLAGS =
+TOOLCHAIN_ASFLAGS =
+
+# Turn off some ICC warnings -
+# Remark #271 : trailing comma is nonstandard
+# Warning #1478 : function "<func_name>" (declared at line N of "<filename>")
+# error #13368: loop was not vectorized with "vector always assert"
+# error #15527: loop was not vectorized: function call to fprintf cannot be vectorize
+# was declared "deprecated"
+# Warning #11074, 11076: to prevent "inline-max-size" warnings.
+WERROR_FLAGS := -Wall -w2 -diag-disable 271 -diag-warning 1478
+WERROR_FLAGS += -diag-disable 13368 -diag-disable 15527
+WERROR_FLAGS += -diag-disable 188
+WERROR_FLAGS += -diag-disable 11074 -diag-disable 11076 -Wdeprecated
+
+ifeq ($(RTE_DEVEL_BUILD),y)
+WERROR_FLAGS += -Werror-all
+endif
+
+# process cpu flags
+include $(RTE_SDK)/mk/toolchain/$(RTE_TOOLCHAIN)/rte.toolchain-compat.mk
+
+export CC AS AR LD OBJCOPY OBJDUMP STRIP READELF
+export TOOLCHAIN_CFLAGS TOOLCHAIN_LDFLAGS TOOLCHAIN_ASFLAGS