summaryrefslogtreecommitdiffstats
path: root/src/test/alpine-edge/Dockerfile.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/alpine-edge/Dockerfile.in')
-rw-r--r--src/test/alpine-edge/Dockerfile.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/test/alpine-edge/Dockerfile.in b/src/test/alpine-edge/Dockerfile.in
new file mode 100644
index 00000000..2ffed1c1
--- /dev/null
+++ b/src/test/alpine-edge/Dockerfile.in
@@ -0,0 +1,8 @@
+FROM alpine:%%os_version%%
+COPY install-deps.sh /root/
+COPY APKBUILD.in /root/alpine/APKBUILD.in
+RUN apk --update --no-cache add bash sudo
+RUN if test %%USER%% != root ; then adduser -D -H -u %%user_id%% %%USER%% && echo '%%USER%% ALL=(ALL) NOPASSWD:ALL' >> /etc/sudoers ; fi
+# build dependencies
+RUN cd /root ; ./install-deps.sh
+