summaryrefslogtreecommitdiffstats
path: root/gnulib-tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 17:39:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 17:39:29 +0000
commit8ffec2a3aba6f114784e11f89ef1d57a096ae540 (patch)
treeccebcbad06203e8241a8e7249f8e6c478a3682ea /gnulib-tests/Makefile.am
parentInitial commit. (diff)
downloadcoreutils-8ffec2a3aba6f114784e11f89ef1d57a096ae540.tar.xz
coreutils-8ffec2a3aba6f114784e11f89ef1d57a096ae540.zip
Adding upstream version 8.32.upstream/8.32upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gnulib-tests/Makefile.am')
-rw-r--r--gnulib-tests/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnulib-tests/Makefile.am b/gnulib-tests/Makefile.am
new file mode 100644
index 0000000..edaa0a7
--- /dev/null
+++ b/gnulib-tests/Makefile.am
@@ -0,0 +1,20 @@
+include gnulib.mk
+
+AM_CFLAGS = $(GNULIB_TEST_WARN_CFLAGS) $(WERROR_CFLAGS)
+
+# A few tests are inherently warning-evoking.
+# In the typical case where we use -Werror, exempt the few offenders.
+
+# test-xvasprintf.c: In function 'test_xasprintf':
+# test-xvasprintf.c:100: error: format not a string literal and no \
+# format arguments [-Wformat-security]
+test_xvasprintf_CFLAGS = $(AM_CFLAGS) \
+ `test -n '$(WERROR_CFLAGS)' && echo ' -Wno-format-security'`
+
+# test-lock.c: In function 'lock_mutator_thread':
+# test-lock.c:148: error: cast from function call of type 'pthread_t' to \
+# non-matching type 'void *' [-Wbad-function-cast]
+test_lock_CFLAGS = $(AM_CFLAGS) \
+ `test -n '$(WERROR_CFLAGS)' && echo ' -Wno-bad-function-cast'`
+test_tls_CFLAGS = $(AM_CFLAGS) \
+ `test -n '$(WERROR_CFLAGS)' && echo ' -Wno-bad-function-cast'`