summaryrefslogtreecommitdiffstats
path: root/tests/t-option-dry-run/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 09:40:31 +0000
commitb86570f63e533abcbcb97c2572e0e5732a96307b (patch)
treecabc83be691530ae685c45a8bc7620ccc0e1ebdf /tests/t-option-dry-run/Makefile
parentInitial commit. (diff)
downloaddpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.tar.xz
dpkg-b86570f63e533abcbcb97c2572e0e5732a96307b.zip
Adding upstream version 1.20.13.upstream/1.20.13upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-option-dry-run/Makefile')
-rw-r--r--tests/t-option-dry-run/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/t-option-dry-run/Makefile b/tests/t-option-dry-run/Makefile
new file mode 100644
index 0000000..b534a41
--- /dev/null
+++ b/tests/t-option-dry-run/Makefile
@@ -0,0 +1,32 @@
+TESTS_DEB := pkg-normal
+
+include ../Test.mk
+
+test-case:
+ # Make sure the package is not there
+ $(DPKG_PURGE) pkg-normal
+
+ # Simulate unpacking a package
+ $(DPKG_UNPACK) --dry-run pkg-normal.deb
+ $(call pkg_is_not_installed,pkg-normal)
+ $(DPKG_INSTALL) --dry-run pkg-normal.deb
+ $(call pkg_is_not_installed,pkg-normal)
+
+ $(DPKG_UNPACK) pkg-normal.deb
+
+ # Simulate configuring a package
+ $(DPKG_CONFIGURE) --dry-run pkg-normal
+ $(call pkg_status_is,pkg-normal,install ok unpacked)
+
+ $(DPKG_CONFIGURE) pkg-normal
+
+ # Simulate removing and purging a package
+ $(DPKG_REMOVE) --dry-run pkg-normal
+ $(call pkg_is_installed,pkg-normal)
+ $(DPKG_PURGE) --dry-run pkg-normal
+ $(call pkg_is_installed,pkg-normal)
+
+ # XXX: Complete
+
+test-clean:
+ $(DPKG_PURGE) pkg-normal