summaryrefslogtreecommitdiffstats
path: root/dom/html/HTMLSummaryElement.h
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /dom/html/HTMLSummaryElement.h
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/html/HTMLSummaryElement.h')
-rw-r--r--dom/html/HTMLSummaryElement.h57
1 files changed, 57 insertions, 0 deletions
diff --git a/dom/html/HTMLSummaryElement.h b/dom/html/HTMLSummaryElement.h
new file mode 100644
index 0000000000..164a36dd1c
--- /dev/null
+++ b/dom/html/HTMLSummaryElement.h
@@ -0,0 +1,57 @@
+/* -*- Mode: C++; tab-width: 8; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* vim: set ts=8 sts=2 et sw=2 tw=80: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#ifndef mozilla_dom_HTMLSummaryElement_h
+#define mozilla_dom_HTMLSummaryElement_h
+
+#include "mozilla/Attributes.h"
+#include "nsGenericHTMLElement.h"
+
+namespace mozilla {
+namespace dom {
+class HTMLDetailsElement;
+
+// HTMLSummaryElement implements the <summary> tag, which is used as a summary
+// or legend of the <details> tag. Please see the spec for more information.
+// https://html.spec.whatwg.org/multipage/forms.html#the-details-element
+//
+class HTMLSummaryElement final : public nsGenericHTMLElement {
+ public:
+ using NodeInfo = mozilla::dom::NodeInfo;
+
+ explicit HTMLSummaryElement(already_AddRefed<NodeInfo>&& aNodeInfo)
+ : nsGenericHTMLElement(std::move(aNodeInfo)) {}
+
+ NS_IMPL_FROMNODE_HTML_WITH_TAG(HTMLSummaryElement, summary)
+
+ nsresult Clone(NodeInfo*, nsINode** aResult) const override;
+
+ nsresult PostHandleEvent(EventChainPostVisitor& aVisitor) override;
+
+ bool IsHTMLFocusable(bool aWithMouse, bool* aIsFocusable,
+ int32_t* aTabIndex) override;
+
+ int32_t TabIndexDefault() override;
+
+ // Return true if this is the first summary element child of a details or the
+ // default summary element generated by DetailsFrame.
+ bool IsMainSummary() const;
+
+ // Return the details element which contains this summary. Otherwise return
+ // nullptr if there is no such details element.
+ HTMLDetailsElement* GetDetails() const;
+
+ protected:
+ virtual ~HTMLSummaryElement();
+
+ JSObject* WrapNode(JSContext* aCx,
+ JS::Handle<JSObject*> aGivenProto) override;
+};
+
+} // namespace dom
+} // namespace mozilla
+
+#endif /* mozilla_dom_HTMLSummaryElement_h */