summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ChildNode.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /dom/webidl/ChildNode.webidl
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/ChildNode.webidl')
-rw-r--r--dom/webidl/ChildNode.webidl26
1 files changed, 26 insertions, 0 deletions
diff --git a/dom/webidl/ChildNode.webidl b/dom/webidl/ChildNode.webidl
new file mode 100644
index 0000000000..3b1254638d
--- /dev/null
+++ b/dom/webidl/ChildNode.webidl
@@ -0,0 +1,26 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://dom.spec.whatwg.org/#interface-childnode
+ */
+
+interface mixin ChildNode {
+ [CEReactions, Throws, Unscopable]
+ void before((Node or DOMString)... nodes);
+ [CEReactions, Throws, Unscopable]
+ void after((Node or DOMString)... nodes);
+ [CEReactions, Throws, Unscopable]
+ void replaceWith((Node or DOMString)... nodes);
+ [CEReactions, Unscopable]
+ void remove();
+};
+
+interface mixin NonDocumentTypeChildNode {
+ [Pure]
+ readonly attribute Element? previousElementSibling;
+ [Pure]
+ readonly attribute Element? nextElementSibling;
+};