summaryrefslogtreecommitdiffstats
path: root/extensions/spellcheck/hunspell/update.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /extensions/spellcheck/hunspell/update.sh
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/spellcheck/hunspell/update.sh')
-rwxr-xr-xextensions/spellcheck/hunspell/update.sh30
1 files changed, 30 insertions, 0 deletions
diff --git a/extensions/spellcheck/hunspell/update.sh b/extensions/spellcheck/hunspell/update.sh
new file mode 100755
index 0000000000..999b321602
--- /dev/null
+++ b/extensions/spellcheck/hunspell/update.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+if [ $# -lt 1 ]; then
+ echo update.sh "<release tag name>"
+ exit 1
+fi
+
+hunspell_dir=`dirname $0`
+
+tmpclonedir=$(mktemp -d)
+git clone https://github.com/hunspell/hunspell --depth 1 --branch $1 ${tmpclonedir}
+# Back up mozilla files
+cp ${hunspell_dir}/src/moz.build ${tmpclonedir}/src/hunspell
+cp ${hunspell_dir}/src/moz.yaml ${tmpclonedir}/src/hunspell
+
+rm -rf ${hunspell_dir}/src
+cp -r ${tmpclonedir}/src/hunspell/ ${hunspell_dir}/src
+cp ${tmpclonedir}/license.hunspell ${hunspell_dir}/src
+cp ${tmpclonedir}/license.myspell ${hunspell_dir}/src
+cp ${tmpclonedir}/license.hunspell ${hunspell_dir}/src/LICENSE
+cp ${tmpclonedir}/README ${hunspell_dir}/src
+rm ${hunspell_dir}/src/Makefile.am
+rm ${hunspell_dir}/src/hunvisapi.h.in
+rm ${hunspell_dir}/src/hunzip.cxx
+rm ${hunspell_dir}/src/hunzip.hxx
+rm ${hunspell_dir}/src/utf_info.cxx
+rm -rf ${tmpclonedir}
+
+cd ${hunspell_dir}/src
+patch -p5 < ../patches/bug1410214.patch