summaryrefslogtreecommitdiffstats
path: root/gfx/wgpu/dummy
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /gfx/wgpu/dummy
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/wgpu/dummy')
-rw-r--r--gfx/wgpu/dummy/Cargo.toml16
-rw-r--r--gfx/wgpu/dummy/README.md3
-rw-r--r--gfx/wgpu/dummy/src/lib.rs3
3 files changed, 22 insertions, 0 deletions
diff --git a/gfx/wgpu/dummy/Cargo.toml b/gfx/wgpu/dummy/Cargo.toml
new file mode 100644
index 0000000000..3d253f05ed
--- /dev/null
+++ b/gfx/wgpu/dummy/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "dummy"
+version = "0.1.0"
+authors = [
+ "Dzmitry Malyshau <kvark@mozilla.com>",
+]
+edition = "2018"
+publish = false
+
+[features]
+
+[dependencies.wgc]
+path = "../wgpu-core"
+package = "wgpu-core"
+version = "0.6"
+features = ["serial-pass", "trace"]
diff --git a/gfx/wgpu/dummy/README.md b/gfx/wgpu/dummy/README.md
new file mode 100644
index 0000000000..5a95a787a5
--- /dev/null
+++ b/gfx/wgpu/dummy/README.md
@@ -0,0 +1,3 @@
+# wgpu dummy
+
+This is a dummy build target that makes `cargo check` and `cargo test` in the workspace to cover all the API.
diff --git a/gfx/wgpu/dummy/src/lib.rs b/gfx/wgpu/dummy/src/lib.rs
new file mode 100644
index 0000000000..e0032240a4
--- /dev/null
+++ b/gfx/wgpu/dummy/src/lib.rs
@@ -0,0 +1,3 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */