summaryrefslogtreecommitdiffstats
path: root/gfx/wr/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /gfx/wr/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/wr/Cargo.toml')
-rw-r--r--gfx/wr/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/gfx/wr/Cargo.toml b/gfx/wr/Cargo.toml
new file mode 100644
index 0000000000..e72822d5fc
--- /dev/null
+++ b/gfx/wr/Cargo.toml
@@ -0,0 +1,27 @@
+[workspace]
+members = [
+ "direct-composition",
+ "examples",
+ "webrender",
+ "webrender_api",
+ "wrench",
+ "example-compositor/compositor",
+ "tileview",
+]
+
+[profile.release]
+debug = true
+panic = "abort"
+
+[profile.dev]
+panic = "abort"
+
+# Running wrench on android built with master cargo-apk results in a crash
+# due to a mismatched version of android_glue (a dependency of winit).
+# Override it to use a suitable version of android_glue.
+# See https://github.com/rust-windowing/android-rs-glue/issues/239.
+# This can be removed once a new version of android_glue is published to crates.io.
+[patch.crates-io]
+android_glue = { git = "https://github.com/rust-windowing/android-rs-glue.git", rev = "e3ac6edea5814e1faca0c31ea8fac6877cb929ea" }
+# this is a version that fixes some incompatibilites with newer rust/aarch64
+winit = { version = "0.19", git = "https://github.com/jrmuizel/winit", branch="wr" }