summaryrefslogtreecommitdiffstats
path: root/layout/tools/recording/RecordingCmdLine.jsm
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /layout/tools/recording/RecordingCmdLine.jsm
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'layout/tools/recording/RecordingCmdLine.jsm')
-rw-r--r--layout/tools/recording/RecordingCmdLine.jsm69
1 files changed, 69 insertions, 0 deletions
diff --git a/layout/tools/recording/RecordingCmdLine.jsm b/layout/tools/recording/RecordingCmdLine.jsm
new file mode 100644
index 0000000000..c22e6504e9
--- /dev/null
+++ b/layout/tools/recording/RecordingCmdLine.jsm
@@ -0,0 +1,69 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+function RecordingCmdLineHandler() {}
+RecordingCmdLineHandler.prototype = {
+ /* nsISupports */
+ QueryInterface: ChromeUtils.generateQI(["nsICommandLineHandler"]),
+
+ /* nsICommandLineHandler */
+ handle: function handler_handle(cmdLine) {
+ var args = {};
+ args.wrappedJSObject = args;
+ try {
+ var uristr = cmdLine.handleFlagWithParam("recording", false);
+ if (uristr == null) {
+ return;
+ }
+ try {
+ args.uri = cmdLine.resolveURI(uristr).spec;
+ } catch (e) {
+ return;
+ }
+ } catch (e) {
+ cmdLine.handleFlag("recording", true);
+ }
+
+ /**
+ * Manipulate preferences by adding to the *default* branch. Adding
+ * to the default branch means the changes we make won't get written
+ * back to user preferences.
+ *
+ * We want to do this here rather than in reftest.js because it's
+ * important to set the recording pref before the platform Init gets
+ * called.
+ */
+ var prefs = Cc["@mozilla.org/preferences-service;1"].getService(
+ Ci.nsIPrefService
+ );
+ var branch = prefs.getDefaultBranch("");
+
+ try {
+ var outputstr = cmdLine.handleFlagWithParam("recording-output", false);
+ if (outputstr != null) {
+ branch.setCharPref("gfx.2d.recordingfile", outputstr);
+ }
+ } catch (e) {}
+
+ branch.setBoolPref("gfx.2d.recording", true);
+
+ var wwatch = Cc["@mozilla.org/embedcomp/window-watcher;1"].getService(
+ Ci.nsIWindowWatcher
+ );
+ wwatch.openWindow(
+ null,
+ "chrome://recording/content/recording.xhtml",
+ "_blank",
+ "chrome,dialog=no,all",
+ args
+ );
+ cmdLine.preventDefault = true;
+ },
+
+ helpInfo:
+ " --recording <file> Record drawing for a given URL.\n" +
+ " --recording-output <file> Specify destination file for a drawing recording.\n",
+};
+
+var EXPORTED_SYMBOLS = ["RecordingCmdLineHandler"];