summaryrefslogtreecommitdiffstats
path: root/third_party/python/fluent.migrate/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/python/fluent.migrate/setup.py
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/fluent.migrate/setup.py')
-rw-r--r--third_party/python/fluent.migrate/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/python/fluent.migrate/setup.py b/third_party/python/fluent.migrate/setup.py
new file mode 100644
index 0000000000..9d7bcfa9ab
--- /dev/null
+++ b/third_party/python/fluent.migrate/setup.py
@@ -0,0 +1,34 @@
+#!/usr/bin/env python
+
+from setuptools import setup
+
+setup(
+ name='fluent.migrate',
+ version='0.10',
+ description='Toolchain to migrate legacy translation to Fluent.',
+ author='Mozilla',
+ author_email='l10n-drivers@mozilla.org',
+ license='APL 2',
+ url='https://hg.mozilla.org/l10n/fluent-migration/',
+ keywords=['fluent', 'localization', 'l10n'],
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.7',
+ ],
+ packages=['fluent', 'fluent.migrate'],
+ install_requires=[
+ 'compare-locales >=8.1, <9.0',
+ 'fluent.syntax >=0.18.0, <0.19',
+ 'six',
+ ],
+ extras_require={
+ 'hg': ['python-hglib',],
+ },
+ tests_require=[
+ 'mock',
+ ],
+ test_suite='tests.migrate'
+)