summaryrefslogtreecommitdiffstats
path: root/third_party/python/iso8601/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/python/iso8601/setup.py
parentInitial commit. (diff)
downloadfirefox-upstream.tar.xz
firefox-upstream.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/iso8601/setup.py')
-rw-r--r--third_party/python/iso8601/setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/python/iso8601/setup.py b/third_party/python/iso8601/setup.py
new file mode 100644
index 0000000000..d5c8782f07
--- /dev/null
+++ b/third_party/python/iso8601/setup.py
@@ -0,0 +1,25 @@
+import os
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils import setup
+
+long_description = open(os.path.join(os.path.dirname(__file__), "README.rst")).read()
+
+setup(
+ name="iso8601",
+ version="0.1.12",
+ description=long_description.split("\n")[0],
+ long_description=long_description,
+ author="Michael Twomey",
+ author_email="micktwomey+iso8601@gmail.com",
+ url="https://bitbucket.org/micktwomey/pyiso8601",
+ packages=["iso8601"],
+ license="MIT",
+ classifiers=[
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ ],
+)