summaryrefslogtreecommitdiffstats
path: root/third_party/python/taskcluster-urls/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:29:10 +0000
commit2aa4a82499d4becd2284cdb482213d541b8804dd (patch)
treeb80bf8bf13c3766139fbacc530efd0dd9d54394c /third_party/python/taskcluster-urls/setup.py
parentInitial commit. (diff)
downloadfirefox-2aa4a82499d4becd2284cdb482213d541b8804dd.tar.xz
firefox-2aa4a82499d4becd2284cdb482213d541b8804dd.zip
Adding upstream version 86.0.1.upstream/86.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/taskcluster-urls/setup.py')
-rw-r--r--third_party/python/taskcluster-urls/setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/python/taskcluster-urls/setup.py b/third_party/python/taskcluster-urls/setup.py
new file mode 100644
index 0000000000..f60108151b
--- /dev/null
+++ b/third_party/python/taskcluster-urls/setup.py
@@ -0,0 +1,28 @@
+import json
+import os
+from setuptools import setup
+
+package_json = os.path.join(os.path.dirname(os.path.abspath(__file__)), 'package.json')
+with open(package_json) as f:
+ version = json.load(f)['version']
+
+setup(
+ name='taskcluster-urls',
+ description='Standardized url generator for taskcluster resources.',
+ long_description=open(os.path.join(os.path.dirname(__file__), 'README.md')).read(),
+ long_description_content_type='text/markdown',
+ url='https://github.com/taskcluster/taskcluster-lib-urls',
+ version=version,
+ packages=['taskcluster_urls'],
+ author='Brian Stack',
+ author_email='bstack@mozilla.com',
+ license='MPL2',
+ classifiers=[
+ 'License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ ],
+)